ED 5.0 missing on petrol. - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 13 (permalink) Old 07-04-03, 08:27 PM Thread Starter
Registered User
 
Join Date: May 2003
Posts: 14
ED 5.0 missing on petrol.

Hi,

I have an ED 5 litre that misfires on petrol (also hs gas and runs perfect). Misfire only occurs when the torque convertor locks up at 80kph. When the revs come up to around 2000 it dissapears?

On gas it runs fine so I dont think its an electrical problem. I have replaced the leads with genuine ford + plugs. Have a new rotor plus cap but have been reluctant to fit. Throttle body has also recently been cleaned by my local dealer.

Thinking it could be a bad injector patern or stale fuel?

Any other ideas?

technic is offline  
Sponsored Links
Advertisement
 
post #2 of 13 (permalink) Old 07-04-03, 10:17 PM
300+rwkw DC LTD Member
 
LTDHO's Avatar
 
Join Date: Jul 2001
Location: Melbourne, Vic
Age: 42
Posts: 1,622
Depending on the kilometers ya done, sound's like the injectors need reco-ing...

LTDHO
Power by me 360rwkw
Check out E Series Owners Club on Facebook
LTDHO is offline  
post #3 of 13 (permalink) Old 07-05-03, 09:47 PM Thread Starter
Registered User
 
Join Date: May 2003
Posts: 14
Re: ED 5.0 missing on petrol.

Its done 160k so I should prolly get this done?
technic is offline  
post #4 of 13 (permalink) Old 07-06-03, 12:03 AM
Registered User
 
Join Date: Sep 2002
Location: 27 00S 153 07E
Posts: 1,944
Re: ED 5.0 missing on petrol.

Do you run much petrol through it, should really run about 20 litres/month to keep the injectors in shape.

"I married Miss Right. I just didn't know her first name was Always."
TopGhia is offline  
post #5 of 13 (permalink) Old 07-06-03, 06:57 AM
No longer around
 
MADNC_8's Avatar
 
Join Date: Jun 2002
Location: Geelong
Age: 35
Posts: 4,882
Re: ED 5.0 missing on petrol.

my NC was missing pretty badly just after i got it at startup and around where you say yours is doing it.

what i found was on the dizzy cap, the contact that touch's the rotor was broken, and it had huge black areas all over where it was arking to 'try' and get a spark .

anywayz new cap and button, new leads (tehy were due for replacement) and she was all good again

i will warn (scare) you though from ford spare parts (teh only place you can buy a 5 litre dizzy cap) the list price is $233.43 and the rotor button was list $24.53

thank goodness i get ford employee discount $118.18 + $13.64 seems like a much better price

btw you should run the car on petrol at a minimum of: on startup, and shutdown, and 5 kms after starting/before coming home if its possible

this will keep injectors from dying
MADNC_8 is offline  
post #6 of 13 (permalink) Old 07-06-03, 03:32 PM
300+rwkw DC LTD Member
 
LTDHO's Avatar
 
Join Date: Jul 2001
Location: Melbourne, Vic
Age: 42
Posts: 1,622
I agree with NC.

It could be the Dizzy and Leads. Basically everything that should have been replace or done at the 100,000 service.

Although if is was elect problem you would experience it with both fuels!

I bought my distributor and leads from Eagle Performance in Dandenong. Sorry can't remember the prices but I'm sure it was cheaper or better than Ford. (otherwise I would have gone to Ford)

Get the injectors done and make sure you replace the 'O' rings as well, if they are really bad, the filter also.

LTDHO
Power by me 360rwkw
Check out E Series Owners Club on Facebook
LTDHO is offline  
post #7 of 13 (permalink) Old 07-06-03, 03:54 PM
Lamahs approve of manuals
 
Join Date: Mar 2003
Location: Sydney, Australia
Age: 39
Posts: 1,382
Dizzy cap for $200+ :WTF: !?!?
For the EL8, bought one one a coupla months ago from a local spares place for like $35, another $15 or so for the rotor button . . .

sheeeiiittee . . . its 95% plastic . . .
XR8 Lamah is offline  
post #8 of 13 (permalink) Old 07-06-03, 04:19 PM
300+rwkw DC LTD Member
 
LTDHO's Avatar
 
Join Date: Jul 2001
Location: Melbourne, Vic
Age: 42
Posts: 1,622
Yeah but the extra $200 is for Gen-u-ine Ford!!!

ha ha ha

LTDHO
Power by me 360rwkw
Check out E Series Owners Club on Facebook
LTDHO is offline  
post #9 of 13 (permalink) Old 07-14-03, 02:53 AM Thread Starter
Registered User
 
Join Date: May 2003
Posts: 14
Re: ED 5.0 missing on petrol.

Thanks guys. I was going to replace the dizzy but this was only occuring on petrol. Had the injectors serviced and all is well.

Thanks :).
technic is offline  
post #10 of 13 (permalink) Old 07-14-03, 05:38 AM
No longer around
 
MADNC_8's Avatar
 
Join Date: Jun 2002
Location: Geelong
Age: 35
Posts: 4,882
thats cool then
MADNC_8 is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Engine Specific Tech > Windsor Tech


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
petrol prices sideshowfreak The Pub 1 03-03-03 06:37 AM
A strategy to reduce the price of petrol XR8fella The Pub 2 02-26-03 10:16 PM
Holiday bonus for petrol companies Falchoon The Pub 1 10-03-02 11:36 PM
New tax and new petrol Falchoon The Pub 6 03-20-02 09:26 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome