injected 5L issues - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
» Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Engine Specific Tech > Windsor Tech
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 07-28-2004, 03:29   #1 (permalink)
Big & little v8's
 
Join Date: Oct 2003
Location: Perth
Age: 33
Posts: 11
Question injected 5L issues

Not long ago, my '96 v8 fairlane started giving me problems. Such as running like crap, stalling, blowing black smoke and not starting. Disconnected the suspect MAF sensor (since these are obvious symptoms) and the car ran fine, however, there is a hunting idle, when backing off the throttle. Is this relaited to the car not having a MAF at the moment, or is it something else?

I am getting a new sensor, but not from this deserted rubbish island, since they want $1500 for it, and its $250~ US new for the sensor alone from the states.
__________________
Nf2 v8 ss extractors & zaust - daily driver, 6Km/litre.
merc 6.9 w/ mods - weekend beast, 3Km/litre.

I have concern for the environment.
Davey is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-28-2004, 04:05   #2 (permalink)
Two SC 61's = trouble
 
ebxr8240's Avatar
 
Join Date: Jul 2001
Location: Penrith,nswAus/Morrinville.NZ
Age: 60
Posts: 6,360
Re: injected 5L issues

Try cleaning it with white spirits or similar..There maybe gunk on hotwire??
__________________
Don't be afraid to try something new. Remember, amateurs built the Ark...Professionals built the Titanic!
.
Tuned & maintained by "Peppertree Perfmormance". Dart block, Scat 4340 steel crank, Custom C.P pistons.Oliver rods.. Mal Wood twin plate clutch.. Twin SC61/2's,482 rwkw/ 645 rwhp..
Passengers, myocardial infarction material..
R.I.P Possum...
ebxr8240 is offline   Reply With Quote
Old 07-28-2004, 04:39   #3 (permalink)
Veteran Ford Member
 
Join Date: Jan 2003
Location: Melbourne, Australia
Age: 28
Posts: 5,083
Re: injected 5L issues

Not running an oil type air filter are you?
psycho chicken is offline   Reply With Quote
Old 07-28-2004, 16:38   #4 (permalink)
Vic
Underachiever in training
 
Vic's Avatar
 
Join Date: Sep 2003
Location: Melbourne
Posts: 100
Re: injected 5L issues

I had a dodgy MAF. While I was off getting a reco'd MAF, I disconnected the original ( it ran quite rich while disconnected) and noticed whenever I came off the throttle the engine would hunt a little as it came down to idle. Oh, the reco'd MAF cost me $350 and I found shortly after that other places would sell them for down around $300. Ford on the other hand wanted about $1350 for a new throttle body assembly.
__________________
Never argue with an idiot. They drag you down to their level, and they beat you with experience.
Vic is offline   Reply With Quote
Old 07-28-2004, 16:41   #5 (permalink)
do YOU have rubber?
 
!Gn|T|0n's Avatar
 
Join Date: Dec 2002
Location: Brisbane
Age: 34
Posts: 2,357
Re: injected 5L issues

Does NZ still have the 70mm MAFs for sale? He wanted $200 IIRC.
!Gn|T|0n is offline   Reply With Quote
Old 07-28-2004, 21:39   #6 (permalink)
Big & little v8's
 
Join Date: Oct 2003
Location: Perth
Age: 33
Posts: 11
Re: injected 5L issues

Quote:
Originally Posted by ebxr8240
Try cleaning it with white spirits or similar..There maybe gunk on hotwire??
Nah, shes rooted mate, I tried that first. Of the 2 components in the airstream, the heater and the temperature sensor, the heaters actually physically broken its casing.
__________________
Nf2 v8 ss extractors & zaust - daily driver, 6Km/litre.
merc 6.9 w/ mods - weekend beast, 3Km/litre.

I have concern for the environment.
Davey is offline   Reply With Quote
Old 07-29-2004, 01:00   #7 (permalink)
Two SC 61's = trouble
 
ebxr8240's Avatar
 
Join Date: Jul 2001
Location: Penrith,nswAus/Morrinville.NZ
Age: 60
Posts: 6,360
Re: injected 5L issues

Quote:
Originally Posted by Davey
Nah, shes rooted mate, I tried that first. Of the 2 components in the airstream, the heater and the temperature sensor, the heaters actually physically broken its casing.
YEP she's stuffed !!! Get a 70mm maf ???
__________________
Don't be afraid to try something new. Remember, amateurs built the Ark...Professionals built the Titanic!
.
Tuned & maintained by "Peppertree Perfmormance". Dart block, Scat 4340 steel crank, Custom C.P pistons.Oliver rods.. Mal Wood twin plate clutch.. Twin SC61/2's,482 rwkw/ 645 rwhp..
Passengers, myocardial infarction material..
R.I.P Possum...
ebxr8240 is offline   Reply With Quote
Old 07-29-2004, 03:16   #8 (permalink)
Operation E-Series Hoon™
 
Yagz's Avatar
 
Join Date: Jul 2004
Location: au.vic.somers
Age: 29
Posts: 1,466
Re: injected 5L issues

Hmm, i've just put a k and n panel filter in my xr8, but apparently it will root my maf cos the oil gets onto the elemtns in the maf, and roots it? any truth to this?
__________________
EL2 XR8 - Manual, Exhaust, 70mm MAF - 150.1rwkw
Pics Here
XR6 FOR SALE: Click Here
Quote:
Originally Posted by Yagz
Stop putting stupid yagz quotes in your stupid signatures you stupid people!
Yagz is offline   Reply With Quote
Old 07-29-2004, 03:36   #9 (permalink)
NZ
feed me hey
 
Join Date: Jul 2002
Age: 64
Posts: 4,692
Re: injected 5L issues

Quote:
Originally Posted by !Gn|T|0n
Does NZ still have the 70mm MAFs for sale? He wanted $200 IIRC.
Problems is he needs the sensor and ine are from AU's soo most likely incompatable.

BUT!

I will soon be using the sprint EEC so I may have to use the EBGT maf electronics - not sure on that yet. If I do then I'll have a spare stock sensor. All depends on me getting off my big fat gloupious maximus (scientific term for ass) and adding smartlock which means converting my !gn|t|0n barrel.........
__________________
Dot Aye You
NZ is offline   Reply With Quote
Old 07-29-2004, 03:40   #10 (permalink)
345kw of V8 Windsor Power
 
EDXR8's Avatar
 
Join Date: Jul 2001
Location: Adelaide
Age: 35
Posts: 2,784
Re: injected 5L issues

Quote:
Originally Posted by MYEL 8
Hmm, i've just put a k and n panel filter in my xr8, but apparently it will root my maf cos the oil gets onto the elemtns in the maf, and roots it? any truth to this?
If you use too much oil when you reoil them they will coat the MAF and make the car run like crap till you clean the wires. Otherwise they are fine, I ran a K&N with my MAF for a couple of years and I never had a problem.
EDXR8 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Engine Specific Tech > Windsor Tech



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Contacting Politicians regarding road issues back2thefutura The Pub 10 08-08-2004 19:27
Worked i6 idle and oil pressure issues... Ideas? defective Inline 6 Tech 18 07-23-2004 17:11
BA GT....Problems and more issues..... firefox7 FPV & Tickford Forum 59 02-29-2004 07:23
Fairmont Ghia, what to pay? adamw Australian Falcons 29 12-16-2003 22:47

Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 22:40.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.