oil problem - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 06-08-03, 10:38 AM
tom campbell
Posts: n/a
confused oil problem

I have a rebuilt 302 short block from a '96 expolrer. I put older style '78 heads on with non-adjustible rocker arms. Had a set of pushrods cut 6.35". the roller stock rods were too short, and the '78 rods were too long. every thing went well and the complete motor went in to a '67 Mercury Caliente. Put an Edlebrock performer intake with a 600 performer 4 barrel. The problem is that the motor cranked and ran fine except that it sounded like the lifters were bottoming out. I backed the rocker arms off and was getting 120lbs. of compression with the arms torqued 25lbs. or 15lbs. but then I sasw that the left side was pumping plenty of oil thru the pushrods, but the right side was not pumping any at all. Can't figure out what the problem is. if you can help, I would greatly appreciate it.

Sponsored Links
post #2 of 3 (permalink) Old 06-08-03, 10:12 PM
345kw of V8 Windsor Power
EDXR8's Avatar
Join Date: Jul 2001
Location: Adelaide
Age: 36
Posts: 2,784
All I could think of is if you put the lifters in the wrong way (the oiling holes not facing to the centre of the engine) therefore not getting oil through them). Can't think of anything else.
EDXR8 is offline  
post #3 of 3 (permalink) Old 06-09-03, 05:22 AM
Two SC 61's = trouble
ebxr8240's Avatar
Join Date: Jul 2001
Location: Penrith,nswAus/Morrinville.NZ
Age: 62
Posts: 6,360
Check you're preload on lifters. Holes in pushrods all clear? Seems a clearance problem being one side is o/k the other isn't or an oil gallery is blocked... ???
Has the cam bearings been replaced and installed correctly ????

Don't be afraid to try something new. Remember, amateurs built the Ark...Professionals built the Titanic!
Tuned & maintained by "Peppertree Perfmormance". Dart block, Scat 4340 steel crank, Custom C.P pistons.Oliver rods.. Mal Wood twin plate clutch.. Twin SC61/2's,482 rwkw/ 645 rwhp..
Passengers, myocardial infarction material..
R.I.P Possum...
ebxr8240 is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Engine Specific Tech > Windsor Tech
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Similar Threads
Thread Thread Starter Forum Replies Last Post
302 Oil Pressure Problem Fritz The Cat Cleveland Tech 15 05-15-03 05:38 AM
XR6T oil report esky F6 Typhoon | XR6 Turbo 29 01-11-03 10:39 AM
SHO stopper: Engine problem in high-performance Taurus angers fans Stacy94PGT Ford Worldwide News 0 10-23-02 10:39 PM
How to change oil Falchoon The Pub 3 09-29-02 06:57 PM
Is this lifters or oil supply problem? EA S General Tech 5 03-14-02 08:30 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome