The possessed 5.0 efi revving too high at idle....please help!! - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
» Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Engine Specific Tech > Windsor Tech
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 02-14-2003, 16:23   #1 (permalink)
Registered User
 
Join Date: Jul 2002
Location: Sydney
Posts: 251
The possessed 5.0 efi revving too high at idle....please help!!

Ok - maybe it's not possessed - but weird problems:

Current symptoms:

* at idle all of the sudden the revs started climbing up and up and up......(still climbing after three hail mary's) .......freaky

*after I killed her (did not want fried windsor).. On re - start It would be ok again, then the revs would climb up all over again during normal driving

* seems to be intermittent , good days with no symptoms, bad days with severe over revving (climbing gradually)

Initially thought that the throttle cable was sticking as revs stayed high, installed new cable but still revving high on idle

Checked throttle return spring ( with cable detached), seems to spring back ok - did this with the cable attached and detached, with an assistant depressing the accelarator pedal in all positions, and it sprung back ok

I have run this throttle cable set up for the past two years with no problems.

Im thinking tps swich is rooted ....What do you think?

Help appreciated.
XF 5.0 S is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-14-2003, 19:28   #2 (permalink)
Aussie Falcon Enthusiast
 
Join Date: Feb 2001
Location: Sydney, NSW, Australia
Posts: 478
How high is it revving at idle?

Perhaps you have a sticking ISC bypass solenoid. Some time back my 5L would shoot up to 1.5-2k rpm at idle. Cleaning the ISC-BP fixed it.
anakha is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Engine Specific Tech > Windsor Tech



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
High Idle EAI6 General Tech 10 05-17-2006 03:49
5.0 v8 into my zl fairlane...efi or carbi?? [LIM-OZN] Windsor Tech 6 05-05-2003 05:54
Where to buy performance 5.0 efi aftermarket parts in Sydney? XF 5.0 S General Tech 2 02-17-2003 04:57
A New Boss Born in Australia RPO83 Ford Worldwide News 0 10-16-2002 19:12
I need 5.0 EFI help xafalcon General Tech 8 08-14-2002 23:45

Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 09:56.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.