Sick Pony - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Engine Specific Tech > Windsor Tech
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 03-17-2005, 07:04   #1 (permalink)
Registered User
 
Join Date: Oct 2003
Location: Washington State
Age: 60
Posts: 25
confused Sick Pony

Engine background:
1982 Mustang 5.0 HO
B&N supercharger w/7 psi max boost
Rebuilt engine 9/2003 about 8,000 miles ago
Holley 850 double pumper
Competition Cam 262 XE

Car's been running roughly recently, unsteady idle, hesitation

Checked oil level last week and had to add 3 1/2 quarts of oil.
This morning I had to put in 2 gallons of water in the radiator.
This evening when I got home, I noticed oil or steam (couldn't tell, could be both) out the exhaust pipes at idle.
No noticeable oil or water leaks from engine.
Removed breather caps on valve covers and some evidence of water in the caps (frothy sludge and condensation inside the caps).
Pulled dip stick and no sign of water. Water in radiator looks ok, but low.
I removed the spark plugs. #6 had some discoloration, others were ok.
Compression test: All read 145 to 150 psi except #8 at 135 psi.
[/IMG][IMG]
Discovered boost pressure sensing line to pressure gauge was disconnect at the intake manifold.
Located puddles of black oil on intake manifold drivers side between two rear runners.

I plan to remove valve covers next. Suspect Intake manifold gasket leak. Blown head gasket a possibility? Hope nothing more serious.

Any comments or helpful suggestions would be appreciated.
Attached Images
File Type: jpg DSC02818b.JPG (34.0 KB, 6 views)
File Type: jpg DSC02819b.JPG (33.3 KB, 0 views)
82 Boss is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Engine Specific Tech > Windsor Tech



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 04:37.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.