webers - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 07-09-2003, 01:35 Thread Starter
Registered User
347's Avatar
Join Date: Jul 2003
Location: Sydney
Posts: 651

anybody here running webers on a windsor?
347 is offline  
Sponsored Links
post #2 of 3 (permalink) Old 07-12-2003, 04:17
Registered User
Join Date: Jun 2003
Location: Melbourne
Posts: 140
Sorry mate, but I know they work alright as long as you keep them tuned, a mate had 8 of them on his XB coupe. Had a custom manifold fabricated for it. Redline probably do a manifold for quad webers, problem with windsors is that all the good parts come from the states and everyone uses holleys over there.
XF__UTE is offline  
post #3 of 3 (permalink) Old 07-12-2003, 17:19
Ford Appreciation Society
EBXR's Avatar
Join Date: Jul 2002
Location: ACT and loving it!
Age: 42
Posts: 3,666
Re: webers

Don't know what info you are after, but try this web site from the US. A few Shelby guys were recommending him.

'67 Mustang V8 4sp... what fun to drive!
EBXR is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Engine Specific Tech > Windsor Tech

Quick Reply

Register Now

In order to be able to post messages on the Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome