Welsh Plugs Windsor 302 - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Engine Specific Tech > Windsor Tech
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 09-13-2004, 08:36   #1 (permalink)
Registered User
 
Join Date: Sep 2004
Posts: 14
Question Welsh Plugs Windsor 302

Can anyone tell me what is the best way to remove the welsh plugs in my 71 Fairlane ZD stock 302 V8 with extractors.

In the last couple of weeks Ive noticed the water level down a little bit in my radiator.

When Im parked I see a small puddle of coolant underneath the car.

I jacked the car up and found one of the plugs has a slight leak.

Should I change all of them or only the leaky one.

The one that is leaky is near the engine mounts on the drivers side.

It looks like a bastard of a job because of the angle of the bottom end and getting to them.

Any help will be greatly appreciated

Novice home maintenance mechanic

Thanks

Buz888








Novice home maintenance mechanic
Buz888 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-13-2004, 18:18   #2 (permalink)
Registered User
 
Join Date: Jun 2002
Posts: 6
Re: Welsh Plugs Windsor 302

I had the same problem on my ZD but it was the welsh plug near the thermostat that was leaking. I got them them all replaced but to do that you have to remove the engine from the car because there are a couple of plugs at the back of the engine.
ZD302 is offline   Reply With Quote
Old 09-13-2004, 18:28   #3 (permalink)
Registered User
 
Join Date: Sep 2004
Posts: 14
Re: Welsh Plugs Windsor 302

Quote:
Originally Posted by ZD302
I had the same problem on my ZD but it was the welsh plug near the thermostat that was leaking. I got them them all replaced but to do that you have to remove the engine from the car because there are a couple of plugs at the back of the engine.
Thanks ZD302,

What a pain in the rear end.

I was kind of hoping I wouldnt need to pull the engine out but it looks like Im going to have to.
Ah well, thats life.
On the bright side I can give the engine a good clean and paint it up.

Thanks
Buz888
Buz888 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Engine Specific Tech > Windsor Tech

Related Reading: Welsh Plugs Windsor 302


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
what spark plugs to run in my windsor? 302_supra Windsor Tech 26 10-19-2004 04:51
5.0 Missing after plugs and leads change NZ Windsor Tech 2 12-03-2003 22:45
A bit of confusions over spark plugs... NZ Windsor Tech 8 12-02-2003 13:09
Colder spark plugs - XR6 plugs for EA Axeman82 Inline 6 Tech 3 06-09-2003 15:39
snafu EB2: welsh plugs rusty Falchoon General Tech 3 05-29-2002 03:14

Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 01:31.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.