5.4 problem - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 02-15-04, 02:15 PM Thread Starter
Registered User
Join Date: Feb 2004
Posts: 1
5.4 problem

I have a 99 f 150 5.4 it is missing real bab at low rpm. With my foot on the brake and holding 1200-1500 rpm it misses like crazy. What is wrong?
nicholsd is offline  
Sponsored Links
post #2 of 2 (permalink) Old 02-16-04, 04:11 PM
DOHC 5.4 Racer
Join Date: Jul 2003
Location: Fla. USA
Posts: 110
Re: 5.4 problem

Check the spark plugs on the rear cyl's. # 4&8 sometimes accumulate water around the sparkplugs/wires.

'97 Cobra dohc 5.4 590+rwhp
Boss 330 is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Engine Specific Tech > Modular Tech
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Similar Threads
Thread Thread Starter Forum Replies Last Post
5.4 problem nicholsd FE (330-428) Tech 1 02-15-04 02:11 PM
Anyone had this gearbox problem??? XR6HP01 Trans | Driveline 16 08-31-03 08:32 PM
SHO stopper: Engine problem in high-performance Taurus angers fans Stacy94PGT Ford Worldwide News 0 10-23-02 10:39 PM
Defective GM engines $30+ Bilion problem. Discovery The Pub 11 03-21-02 07:37 PM
Solution to 5.4 bonnet bulge problem? FM The Pub 9 11-03-01 08:23 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome