Lifter noise from BOSS 290 - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 03-01-04, 01:51 AM Thread Starter
Registered User
Join Date: Feb 2004
Location: Maryborough Qld
Posts: 27
Lifter noise from BOSS 290

I have noticed lifter noise on start up on two occassions with a new BOSS 290 motor. (approx 1500 km)

The first time I had driven the car at highway speed, parked the car and 20 minutes later restarted the engine. The car was on flat ground and the engine would have been still warm from the recent trip.

The second time it was essentially the same sequence except the car was parked on a slight downwards slope.

When the engine was started I could hear a definite tap tap tap tap tap from the top of the motor before it righted itself after two maybe three seconds.

The engine has been started maybe fifty times and I have only noticed this twice.

So what are your thoughts? Is this normal?

Should I instigate an early oil change or even a different brand of oil??
barra56 is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Engine Specific Tech > Modular Tech
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome