Washed engine--03P71--problems now--Help! - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Engine Specific Tech > Modular Tech
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 09-18-2006, 14:31   #1 (permalink)
Registered User
 
Join Date: Sep 2006
Posts: 9
Washed engine--03P71--problems now--Help!

I bought a 03 P71 with 47k miles on it last week. I had the bright idea to spray the engine with simple green and rinse it off. Everything was running fine before I did this. Anyway I was very careful to dry all plug-ins and blow off with air.
**Initially it started up with a really high idle/cel. I unplugged the battery for about an hour and restarted. The idle was normal and the engine smooth, but it is shifting incorrectely and not kicking down as normal. It also seems to be making about 70% power. These are the symptoms as of now. What do I need to do now? What have I ruined? I would appreciate all help and suggestions. I am out of ideas. Will a code reader identify whatever it is I have done? Yes I really must be stupid. Help...Help...Help...please.
Thanks, Jason
03P71alaska is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-24-2006, 11:52   #2 (permalink)
DOHC 5.4 Racer
 
Join Date: Jul 2003
Location: Fla. USA
Posts: 110
Re: Washed engine--03P71--problems now--Help!

Not sure what a P71 is. If is is a sohc it's common to have water fill up the around the COP's. ( Coil on plug units). If that's the case it will short out the coils and cause random to solid missfires.
__________________
'97 Cobra dohc 5.4 590+rwhp
www.Boss330racing.com
Boss 330 is offline   Reply With Quote
Old 12-28-2006, 20:00   #3 (permalink)
Registered User
 
Join Date: Dec 2006
Posts: 15
Re: Washed engine--03P71--problems now--Help!


Dont you know it runs better when it is dirty... LOL
smallblockman is offline   Reply With Quote
Old 01-19-2007, 05:51   #4 (permalink)
Registered User
 
Join Date: Dec 2006
Posts: 24
Re: Washed engine--03P71--problems now--Help!

I would have it hooked up to a reader that can tell you exactly what is wrong with it. Take it to Autozone they have a small OBDII reader and they will hook it up for free. Takes out the guess work.
I would also check all the connections. Electrical and vacuum. Something must have come loose when you hosed off the engine. I have cleaned my
2000 Mustang engine numerous times and never had a problem as you described it. I bet it is something fairly simple.
Tom1222 is offline   Reply With Quote
Old 01-19-2007, 05:52   #5 (permalink)
Registered User
 
Join Date: Dec 2006
Posts: 24
Re: Washed engine--03P71--problems now--Help!

Quote:
Originally Posted by smallblockman

Dont you know it runs better when it is dirty... LOL
Ahh... that reminds me of a song by the Captain and Tenile...
.... Dirt.... Dirt will keep us together...
Tom1222 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Engine Specific Tech > Modular Tech



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 13:38.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.