1976 ford 390 timing problems, please help!!! - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Engine Specific Tech > FE (330-428) Tech
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto EscrowInsurance

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 01-08-2006, 13:56   #1 (permalink)
new ford guy
 
Join Date: Jan 2006
Location: Drummond, OK
Age: 31
Posts: 4
1976 ford 390 timing problems, please help!!!

I have a 1976 ford f-150 4 wheel drive with a FE 390. I have just finished rebuilding the motor. The modifications that the engine includes is a mild cam, headers, edelbrock manifold and carb. It just doesnt seem to be making the power that it should. Does anyone know where number one is on the distributor and what is the proper firing order and what is the correct timing. I have heard several different answers and im trying to get the right one. Please help, Thank you!!!
kyle_ewing is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-22-2006, 22:39   #2 (permalink)
63-1/2 Galaxie
 
Join Date: Sep 2004
Location: Vancouver Island
Posts: 321
Re: 1976 ford 390 timing problems, please help!!!

Firing order for all FE blocks 1-5-4-2-6-3-7-8 anti clockwise rotation. #1 on the distributor is at the 12:30 to 1 o'clock position when you are facing the vehicle. I had a 76 3/4 ton years ago with a stock 390, but can't remember the timing, but usually around 8-12 deg. BTDC. If its a little sluggish for power, check your vacuum advance and make sure its working.
Butchart is offline   Reply With Quote
Old 01-26-2006, 15:39   #3 (permalink)
new ford guy
 
Join Date: Jan 2006
Location: Drummond, OK
Age: 31
Posts: 4
Re: 1976 ford 390 timing problems, please help!!!

yea thats whats the timing were using. Thanks for the help i appreciate it!!
kyle_ewing is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Engine Specific Tech > FE (330-428) Tech



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 06:25.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.