Questions bout 400 - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 10-28-04, 06:53 PM Thread Starter
Join Date: Oct 2004
Age: 29
Posts: 3
Questions bout 400

I have a rebuilt 400 big block, with edlebrock carb, intake. the MSD full ignition system and crane cam. i just put a holley blue electric fule pump on it with a regulator

heres my questions.
1. is the pump supposed to constantly run? i was told that i should put in a check valve or something

2. for the regulator i want to run a return line. whats the proper way for that?

3. i also need to retime it. i dont know the setting so if you know can you post it

im also looking for the stock temp gauge if any one may have one

thank you
Fordboy400 is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Engine Specific Tech > FE (330-428) Tech
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Similar Threads
Thread Thread Starter Forum Replies Last Post
Men's 5 most feared questions russellw The Pub 12 01-27-05 06:29 AM
Trick questions of death! Casper The Pub 47 04-19-04 01:58 AM
AUII/III XR6 questions Gearhead The Pub 14 03-19-04 03:05 PM
XA/XB Coupe (list of noob questions) Truffles General Tech 5 10-12-03 07:24 AM
351m - 400? 1bad77 General Tech 4 09-29-03 04:26 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome