Ba Xr6 Turbo - - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
F6 Typhoon | XR6 Turbo Turbo Talks start here.

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 02-14-09, 08:36 PM Thread Starter
Registered User
Join Date: Feb 2009
Posts: 1
Ba Xr6 Turbo -

Hi All

I have a BA XR6 TURBO, had for about 12 months now, i have recently changed the exhaust to a Xforce 3 1/2 inch with a 4inch dump pipe, although since i have put the exhaust on it wont let me put the foot down, it's like it's chocking would this be because i need a custom tune or could this be something else wrong with it, all comments welcome.
Thanks herturbo
herturbo is offline  
Sponsored Links
post #2 of 2 (permalink) Old 02-15-09, 03:13 AM Administrator
Big Block Ford's Avatar
Join Date: Apr 2001
Posts: 4,748
Re: Ba Xr6 Turbo -

It could be a number of things including the need of a tune for the exhaust but I wouldn't have thought it would be as bad as that without a tune. Perhaps the o2 sensor is having a problem with the new exhaust. Make sure it is plugged in properly if that part of the exhaust was replaced.

71 429SCJ Mustang
Big Block Ford is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Australian Ford's Discussion > F6 Typhoon | XR6 Turbo
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome