Engine light came on & car would not move - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
» Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Australian Ford's Discussion > F6 Typhoon | XR6 Turbo
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

F6 Typhoon | XR6 Turbo Turbo Talks start here.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 07-20-2004, 02:51   #1 (permalink)
Registered User
 
Join Date: Jun 2004
Location: GLADSTONE
Posts: 3
Engine light came on & car would not move

I had a fright in the heart of Brisbane one day when I was coming to a stop at a corner and the engine started to miss and cough, it wouldn't respond to the throttle and the engine light on the dash lit up and the car had no power and would not move. Being quite peeved off and embarrassed I switched the hazard lights on and turned the car off. I then started the engine again and all was fine. A quick stop down to the Ford dealership and asked them what would have happened. They told me something to do with the variable cam valve timing - some valve gets stuck now and again. Since this little mishap she has run fine. Can anybody explain to me what this means and has anybody else had this embarrassing problem?
1QIKXR6T is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-20-2004, 05:50   #2 (permalink)
Mmm, high pressure wash.
 
3Toed's Avatar
 
Join Date: Nov 2001
Location: Sydney, Australia
Age: 39
Posts: 3,086
Re: Engine light came on & car would not move

I remember reading about that a while back. Not sure of the exact details but I think the cam phasers get stuck so the cam timing is out.

Couple of threads on it here:
XR6 not starting
and
My BA lost power

Might not be the same as your problem but it's a start. Good luck tracking it down!
__________________
Slothmobile™ n. (slōthmōbēl)
Off-white EL Series II Falcon GLi Sapphire (4.0L Slothmatic™) with K&N Filtercharger, Tickford Sports Suspension, DBA Longlife Gold (front), DBA Longlife Slotted (rear) and Bendix Ultimates all round. Driven by The Slothman™.

Co-Founding Member of 3FB Inc, or the Ford Forums Food Bandits, where cruising, eating and talking shite is what it's all about. Click here to visit the official (albeit slightly outdated) website!


Quote:
Originally Posted by Team GT Media
We love having 3FB Inc guys around!
3Toed is offline   Reply With Quote
Old 07-20-2004, 06:27   #3 (permalink)
FF Town Mayor
 
XRchic's Avatar
 
Join Date: Mar 2004
Location: Adelaide
Age: 42
Posts: 1,700
Re: Engine light came on & car would not move

Quote:
Originally Posted by 1QIKXR6T
I had a fright in the heart of Brisbane one day when I was coming to a stop at a corner and the engine started to miss and cough, it wouldn't respond to the throttle and the engine light on the dash lit up and the car had no power and would not move. Being quite peeved off and embarrassed I switched the hazard lights on and turned the car off. I then started the engine again and all was fine. A quick stop down to the Ford dealership and asked them what would have happened. They told me something to do with the variable cam valve timing - some valve gets stuck now and again. Since this little mishap she has run fine. Can anybody explain to me what this means and has anybody else had this embarrassing problem?
Do you have a chip of any kind under the bonnet? Mine (NA) did EXACTLY what yours did and it turned out the chip had gotten wet!!!!!
__________________
2003 BA NA XR6, Silhouette, manual, sunroof, premium audio, alarm, window tint, scuff plates, Navman (in TIMEOUT (tm))
JMM DEV3 BA kit
Unichip
Extractors
2.5 inch cat
2.5 inch exhaust
Air intake conversion/pod
Performance plugs
170.0rwkw
14.80 @ 95.33 mph

Founder MTAS (Manual Transmission Appreciation Society)
Founder Society Against Stupid SMS Language
O.F.R. # 138
XRchic is offline   Reply With Quote
Old 08-07-2004, 02:55   #4 (permalink)
BJC
Registered User
 
Join Date: May 2003
Location: Townsville
Posts: 14
Re: Engine light came on & car would not move

1QIKXR6T,

I have had a similar problem with my xr8 though, in the end it ended up being the throttle control unit (TCU). The warning lite ie. engine light. you speak of is in the owners manual and says when this light comes on the TCU has a problem. This could be different in your manual as you have a turbo but hope this helps.

Brett.
BJC is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Australian Ford's Discussion > F6 Typhoon | XR6 Turbo



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Making a Clevo really REV! TTNOS8 Cleveland Tech 162 03-28-2004 01:18
how many forum members does it take to change a light bulb? gm dstroya The Pub 8 12-21-2003 22:47
Service engine light joe Interior | Electrical | ECU 1 10-03-2003 11:55
Falcon XR8 to Continue Sales Momentum RPO83 Australian Falcons 22 01-24-2003 04:40
check engine light? 95Mystique Ford Contour | Ford Mondeo | Mercury Mystique | Ford Telstar 1 04-01-2002 19:26

Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 23:55.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.