turbo damage - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Australian Ford's Discussion > F6 Typhoon | XR6 Turbo
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

F6 Typhoon | XR6 Turbo Turbo Talks start here.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 08-13-2005, 01:40   #1 (permalink)
Registered User
 
Join Date: Aug 2005
Location: adelaide
Age: 48
Posts: 9
turbo damage

just got my ute back from my stage 2 re-tune due to going slower at the drags despite showing more power to find out that the blades or turbine fins look like they have taken on a few bits of gravel and lost!,,,,,,dents and bits missing about the size of pin heads on the edges of impeller,,,,,scratches and pit marks to housing aswell,,,,,,,,,,,,,,,,lost 30 rwkw in two weeks from last tune,,,,,,,,builds up boost slowly ,doesnt hold, then drops at 5000rpm,,,,,,,,,,,,,any clues on what caused this and where the bits of impeller has gone?
scramxr6t is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-13-2005, 04:48   #2 (permalink)
Registered User
 
Glen's Avatar
 
Join Date: Aug 2004
Location: At my desk..
Posts: 207
Re: turbo damage

Quote:
Originally Posted by scramxr6t
just got my ute back from my stage 2 re-tune due to going slower at the drags despite showing more power to find out that the blades or turbine fins look like they have taken on a few bits of gravel and lost!,,,,,,dents and bits missing about the size of pin heads on the edges of impeller,,,,,scratches and pit marks to housing aswell,,,,,,,,,,,,,,,,lost 30 rwkw in two weeks from last tune,,,,,,,,builds up boost slowly ,doesnt hold, then drops at 5000rpm,,,,,,,,,,,,,any clues on what caused this and where the bits of impeller has gone?
Bits of impeller have either gone through your motor or could be trapped in the intercooler somewhere. Sounds like the turbine is most likely out of balance now if pieces are taken out of the impeller, hence the pressure drop under boost. If it is far enough out of balance the impeller wont spin up to speed and could even lock up, bearings in the turbo could even be buggered. Is your air cleaner installed properly or have you had an aftermarket filter installed.

If what went through the turbo had a bit of weight in it (which sound like it could have) it would be very hard for it to drag it from the aircleaner side of the engine over to the turbo side. This may be a long shot but it could be a small piece of casting from the intake casting on top of the rocker cover.

Hope you get it sorted either way mate. Just a couple of suggestions anyway.
Glen is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Australian Ford's Discussion > F6 Typhoon | XR6 Turbo



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 23:30.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.