1966 Fairlane Electrical Problem - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Older Fords > Classic Fords > Fairlane | Torino
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto EscrowInsurance

Fairlane | Torino Discussion area for Fanatics of the Classic Ford Fairlane and Torino Lines.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 08-06-2007, 09:40   #1 (permalink)
Registered User
 
Join Date: Aug 2007
Location: NJ
Age: 24
Posts: 1
1966 Fairlane Electrical Problem

My 1966 Ford Fairlane has been draining the battery. If I jump the car it will run for about 15 minutes or so, and then shutoff. I then turn the key and nothing happens. I pulled the starter off and tested it and it's fine, replaced the alternator, solenoid switch, and starter switch, and I put a new battery in it. Has anyone had a similar problem or has an idea of what I should do next?
THeff66 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-06-2007, 21:31   #2 (permalink)
Flying @ a mile high
 
geos sho's Avatar
 
Join Date: Mar 2007
Location: Denver
Posts: 122
Re: 1966 Fairlane Electrical Problem

ignition switch,ground to body or motor, with the car running can you pull the negative cable off and the car stays running, if it stays running the alt is charging if not alt or voltage reg is bad. but it shouldnt be killing the car that fast.
__________________
my need is speed
geos sho is offline   Reply With Quote
Old 04-06-2008, 09:48   #3 (permalink)
Registered User
 
heyitsmesmitty's Avatar
 
Join Date: Dec 2006
Location: Cape Cod
Posts: 16
Re: 1966 Fairlane Electrical Problem

i'm currently going through the same problem with my 66 fairlane, ame symptoms you have described, i'll let u kno if i figure out whats wrong if i ever figure it out haha. but since ur post is from a while ago, u ever fix the problem with ur fairlane?
heyitsmesmitty is offline   Reply With Quote
Old 02-08-2009, 00:47   #4 (permalink)
Registered User
 
Join Date: Feb 2009
Location: Arkansas
Posts: 1
Re: 1966 Fairlane Electrical Problem

We had problems with our ignition switch doing that on our 67 fairlane. I'll ask my husband if he has any more suggestions. I hope you figure it out.
fordgal0767 is offline   Reply With Quote
Old 02-11-2009, 17:10   #5 (permalink)
Still Da Man
 
mil1ion's Avatar
 
Join Date: Jan 2009
Location: Innisfail Alberta Canada
Posts: 83
Re: 1966 Fairlane Electrical Problem

A Common power drain is from faulty Alternators that short out within the case.

Tech
mil1ion is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Older Fords > Classic Fords > Fairlane | Torino



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 15:04.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.