1966 Galaxie 500 390 valve question - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Older Fords > Classic Fords > Galaxie
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Galaxie Galaxie discussion area

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 06-22-2011, 06:38   #1 (permalink)
Registered User
 
Join Date: Jun 2011
Posts: 1
1966 Galaxie 500 390 valve question

Im puzzled need a little help. I have a 1966 Ford Galaxie with a 390. I bought the car for 350.00 everything works and the car is in straight as an arrow with surface rust on the outside no rust holes and underneath the car has light surface rust my 2001 ford f350 has more rust. Anyways I have a clicking in the valve assembly. I took off the valve covers and one of the valve push rods is really loose. So since the car has sat for awhile I figured it was a stuck lifter. I pulled the manifold and replaced the lifters. Well guess what it didn't fix the problem. Next I thought stuck valve or bent pushrod well they all are fine. I laid a level on the valves to check if they were all level and flat with each other and they were.
So the only deduction I have left is a worn out cam lobe. If anyone knows or has another idea of what it could be please let me know. If it is a cam lobe how hard is it to replace the cam. The car runs like a top just has a clicking sound.
girwin1123 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-22-2011, 08:49   #2 (permalink)
Moderator
 
Join Date: Nov 2008
Posts: 1,067
Re: 1966 Galaxie 500 390 valve question

Even if you did have a worn cam the lifter will take up the slack. You have to measure the
lift in the valves to find out. The most common problem with those engines is the rocker
shafts. They ware and the rocker will twist and hang up. Also check the rocker arm for
ware.
chipset is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Older Fords > Classic Fords > Galaxie



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 08:29.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.