62 Galaxie Video - What´s wrong in Sound? - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Galaxie Galaxie discussion area

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 07-31-09, 03:11 AM Thread Starter
Galaxian
 
Galaxian's Avatar
 
Join Date: Nov 2005
Location: Cologne
Age: 48
Posts: 26
Question 62 Galaxie Video - What´s wrong in Sound?




Hi Folks - made three of this Videos on youTube. Cause I got a Noise at the engine.

Some folks say that´s the Timing chain other say the Lifters. Is it possible for some Professionals here to give me advice?


Oliver



Through the Galaxie and much more beyond...
Galaxian is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 09-01-09, 12:50 AM
63-1/2 Galaxie
 
Join Date: Sep 2004
Location: Vancouver Island
Posts: 323
Re: 62 Galaxie Video - What´s wrong in Sound?

Very hard to figure out the noise Oli. Hope you get that timing gear kit I sent you, should have it soon. Good idea to change it anyway if the motor has over 100,000 miles. At least the price on the kit was good.
Butchart is offline  
post #3 of 4 (permalink) Old 09-01-09, 01:20 AM Thread Starter
Galaxian
 
Galaxian's Avatar
 
Join Date: Nov 2005
Location: Cologne
Age: 48
Posts: 26
biggrin Re: 62 Galaxie Video - What´s wrong in Sound?

Hey Bob - it is not possible to escape from you -LOL - you are here, there and evrywhere I suppose....

Orderlist to my Mechanic is long but neccessary - even the Power Steering Hoses....

Will report...


PS: No Package at this time...



Through the Galaxie and much more beyond...
Galaxian is offline  
post #4 of 4 (permalink) Old 09-02-09, 12:07 AM
63-1/2 Galaxie
 
Join Date: Sep 2004
Location: Vancouver Island
Posts: 323
Re: 62 Galaxie Video - What´s wrong in Sound?

Hi Oli, I have not been on this website for sometime now, just thought I would check it out again and saw your videos. Taking vacation in the Galaxie soon, will log close to 1000 miles or 1600 km. Just changed oil, greased, etc. and changed a cracked vacuum hose to the power brake booster, which if leaked would cause hard brake pedal. Did a lot of checking over and everything looking good. Have own the car now for 22 years and logged about 36,000 miles in those years and just had minor problems couple times on long trip.
So, hopefully everything will work well. Travelling with two other vehicles on this trip and will be entering big car show. Will send some pics if I take any.
Butchart is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Older Fords > Classic Fords > Galaxie
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome