71 Galaxie Has Lost Its Step - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Galaxie Galaxie discussion area

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 12-02-07, 09:46 AM Thread Starter
Registered User
Join Date: Dec 2007
Posts: 2
Question 71 Galaxie Has Lost Its Step

hello everyone, my first post should almost come off as a R.I.P. message for my car but i'm not willing to call it dead yet even with all its problems...

i have a 1971 Galaxie 500 powered by a 6.6L 400 v8, stock from the ground up right down to the 2v motorcraft carb, and C6 trans. but as of a week ago its parked in the yard.

coming home from work one day it all the sudden began driving like i was in wet cement, it lost all power so in an attempt to limp it home, i was less than 1/4 mile away it died, tow it to the house and tear into the motor, find a bent pushrod, so now new rods, new lifters, 2 months ago put on a new fuel pump, rebuilt the carb, even dropped the gas tank and cleaned out the entire fuel system... changed the oil today, transmission fluid level is perfect... but still crank it up purrrs like a kitten just as it should, engine runs fine but it will only baby step along no matter how much gas you give it, could the transmission be shot? or just hurt? it rolls perfectly smooth no jerking or lurching like the tranny is slipping it just refuses to get up and go so i'm at a loss for ideas, any help you guys could give would be great, thanks in advance for any ideas
SuperMidget is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Older Fords > Classic Fords > Galaxie
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome