help 1963 galaxie - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Older Fords > Classic Fords > Galaxie
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Galaxie Galaxie discussion area

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 02-02-2006, 22:24   #1 (permalink)
Registered User
 
Join Date: Feb 2006
Posts: 3
confused help 1963 galaxie

my friend has a 1963 galaxie with a 352 2bbl and a c4. the other day he took it out for a spin and the car died on him. we towed it back to his house and changed out the voltoge regulator,we polarized it, checked the battery for full charge and it is good and checked the generator to see if it was charging and it is; changed out the sparkplugs, ignition coil,and sparkplug wires. and we are still having difficulty getting it to start. when we try to start it the engine and it makes a sound like the starter is not getting enough juice to crank the engine over. earlier my friend took the starter off and tested it with the battery and the gear turned but he said it turned a bit slow pleeeeeease help somebody.
bullitt2001 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-03-2006, 03:13   #2 (permalink)
Registered User
 
lukeh's Avatar
 
Join Date: Jan 2004
Location: Melbourne
Posts: 868
Re: help 1963 galaxie

When you say it died...do you mean the engine cut out while running?or do you mean that it would'nt start again after he turned off with the key last?
lukeh is offline   Reply With Quote
Old 02-03-2006, 11:11   #3 (permalink)
Registered User
 
Join Date: Feb 2006
Posts: 3
Re: help 1963 galaxie

the engine died while he was driving.
bullitt2001 is offline   Reply With Quote
Old 02-03-2006, 20:45   #4 (permalink)
Registered User
 
lukeh's Avatar
 
Join Date: Jan 2004
Location: Melbourne
Posts: 868
Re: help 1963 galaxie

Quote:
Originally Posted by bullitt2001
the engine died while he was driving.
Well if the engine died while driving...that is'nt caused by the starter motor.There are exception's,but in most cases either there is a problem with the fuel system,or the electrical system.So possibly either fuel is'nt coming from the carburettor...or the spark plugs are not getting the correct spark if any.There are alot of other possibilities...but these are the most common fault's.Sometimes something simple like an old fuel filter can block up,and your engine will just die while you are driving...or a wire can just break off with age somewhere and cut off your ignition system.You have to find out what it's not getting and trace it back through the relevant system...Luke!!
lukeh is offline   Reply With Quote
Old 02-06-2006, 22:30   #5 (permalink)
63-1/2 Galaxie
 
Join Date: Sep 2004
Location: Vancouver Island
Posts: 321
Re: help 1963 galaxie

Hi, some times the condenser in the distributor can fail, suggest you check it out or just replace it, they are cheap to buy. I've had that happen on my old Galaxie, but eventually I put in a pertronix ignition which eliminates points and condenser.
Butchart is offline   Reply With Quote
Old 03-08-2006, 20:36   #6 (permalink)
Registered User
 
custom500girl's Avatar
 
Join Date: Mar 2006
Location: Albuquerque NM
Posts: 9
Re: help 1963 galaxie

I would highly recommend installing pertronix in your car. I used to have problems similar to yours in my '67 Galaxie and the points were usually the culprit. Ive got pertronix in my '66 ford now and no problems.
__________________
A guy at work bought a car out of the paper. Ten years later, Bam! Herpes.
custom500girl is offline   Reply With Quote
Old 03-09-2006, 02:02   #7 (permalink)
Registered User
 
atec77's Avatar
 
Join Date: Feb 2005
Posts: 917
Re: help 1963 galaxie

Quote:
Originally Posted by bullitt2001
my friend has a 1963 galaxie with a 352 2bbl and a c4. the other day he took it out for a spin and the car died on him. we towed it back to his house and changed out the voltoge regulator,we polarized it, checked the battery for full charge and it is good and checked the generator to see if it was charging and it is; changed out the sparkplugs, ignition coil,and sparkplug wires. and we are still having difficulty getting it to start. when we try to start it the engine and it makes a sound like the starter is not getting enough juice to crank the engine over. earlier my friend took the starter off and tested it with the battery and the gear turned but he said it turned a bit slow pleeeeeease help somebody.
On those things (y block) its usually the capacitor acroos the points , go find a replacement for the points ( you can get kits to replace them ) and forget it (used to be able to buy a transistor kit 20 years ago)
atec77 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Older Fords > Classic Fords > Galaxie



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 10:01.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.