T10 4spd in a '65 Galaxie? - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Galaxie Galaxie discussion area

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 10-21-08, 01:55 AM Thread Starter
bronkomel
 
Join Date: Aug 2008
Location: Woodland WA
Age: 50
Posts: 2
T10 4spd in a '65 Galaxie?

Anyone have knowledge of this setup? I've got the car, tranny, pedal set,
but need a bell housing and flywheel. Seems the T10 bell housing is unique. BTW I'm running a 428. Thanks

bronkomel is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 10-21-08, 01:59 AM Thread Starter
bronkomel
 
Join Date: Aug 2008
Location: Woodland WA
Age: 50
Posts: 2
Re: T10 4spd in a '65 Galaxie?

Oh, I need a cross member and clutch fork also. I'm not sure if the 65 BB Galaxie had this setup. Thanks
bronkomel is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Older Fords > Classic Fords > Galaxie


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome