XD/E/F/G/H towbar fitting - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 02-11-05, 05:54 AM Thread Starter
Old Fart
Join Date: Oct 2003
Location: Townsville N Q
Age: 40
Posts: 40
XD/E/F/G/H towbar fitting

just wanted to warn you guys, if you havent got a towbar fitted to any of the above utes and plan on fitting 1, its a nightmare. i fitted mine last night and it took close to 2hrs, and that dont include the wiring, which will probably take another 2hrs

i was pretty surprised when i bought my ute, very very tidy XG S-pack, that it didnt have a towbar. which is probably just as well considering its a manual.

anyways if you thinking of fitting a towbar to your ute, give me a yell and i can point you in the right direction. its pretty easy, just time consuming and involves cutting the body (yes you read right)

it almost looks like the designers at ford forgot that customers might actually like a towbar on their ute.

i will post some pics of my ute in the other thread when i give it a bath and take some nice ones. im pretty proud of it, paid fuk all and got a pretty good deal, apart from the lack of aircon.


No longer driver a oil burner, bought me a real car

XG S-Pack Longreach. Manual
boy am i happy
muttaburra is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ute Forum
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Similar Threads
Thread Thread Starter Forum Replies Last Post
Rear recovery point & towbar burnsi Territory 7 01-30-05 02:41 PM
towbar FPV GT General Tech 2 10-26-04 02:01 AM
Towbar or no towbar???!!! EBII Falcon General Tech 9 07-18-04 09:30 PM
Cargo Barrier Fitting Instructions rjflc69 Interior | Electrical | ECU 2 05-24-04 05:17 AM
Issues after fitting extractors to 4.0 six (AU)??? JC-XR8 Inline 6 Tech 3 04-29-04 09:59 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome