1999 Fiesta zetec 1.25 losing 23mph top speed?!!!! - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Fiesta Forum | Ford kA Forum Forum for discussion of the Ford Fiesta. From US to AU discuss this little car and the mods you have done.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 09-23-07, 10:02 AM Thread Starter
Registered User
 
Adam1's Avatar
 
Join Date: Sep 2007
Posts: 11
Smile 1999 Fiesta zetec 1.25 losing 23mph top speed?!!!!

I have a 1999 1.25 Fiesta zetec, 74bhp jobby, recently over the past 3months I have noticed the car has become a lot slower (23mph to be exact!)

I had the car serviced 2 months ago anyway which fell quite well in time as I thought it may solve the problem, however it hasnt?!

The car has always been well maintained for and has never been spared from having the best, it has covered 66,000 miles, 34,000 of them being from myself.

To be fair it has been tested to its limits down the motorway once or twice of which I have managed 113mph with 4 in the car and 16" cosworth alloys on, I know that is not a good idea but it was just a test, from that info you can obviously see that by losing 23mph it now only does 90mph and thats with just me in it!???

I also have the same problem to another post on here where the retention spring has gone in the gearstick/gearbox, could this be related to some abnormal wear in another area due to this problem??

Thanks

Adam

Adam1 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 01-29-09, 05:46 AM
Registered User
 
Join Date: Jan 2009
Posts: 1
Re: 1999 Fiesta zetec 1.25 losing 23mph top speed?!!!!

I've got a T plate 1999 zetec 1.25 SE :)

Strangely enough my spring in my gearbox has been broken now for about 4 or 5 years. The guidance on the gear changes has obviously gone but I'm long used to it by now. Apparently the spring can cost about £9 for the part but the labour to put it in would be a whole gearbox removal and rebuild, which is £350 labour! So I never bothered.

Through the years my little motor has lost a bit of top speed but still manages 110 at a push but used to sit at 115 with ease (has done 120 with 5 people in the car). I'd say 90 mph indicates a bit of an issue though, I would say that is quite a loss in top speed!
D1m3b4g is offline  
post #3 of 3 (permalink) Old 02-22-09, 01:08 PM
Registered User
 
Join Date: Feb 2009
Posts: 26
Re: 1999 Fiesta zetec 1.25 losing 23mph top speed?!!!!

does the car seem to be faster on a cold day? if this is the case then it could be the air charge temp sensor, if not does the car seem to want to go but is holding back? if this is the case then it could be your M.A.F sensor not telling the engine the correct amount of air being metered into the engine!
dave6068 is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Fiesta Forum | Ford kA Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome