4th and 5th gear. - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Fiesta Forum | Ford kA Forum Forum for discussion of the Ford Fiesta. From US to AU discuss this little car and the mods you have done.

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 11-12-08, 11:38 AM Thread Starter
Registered User
Join Date: Nov 2008
Posts: 1
4th and 5th gear.

Hi all,

This is my first post and very glad to have come across this site. I have a slight problem with my KA which is on a S plate, 1.3 model.

The problem is when I'm on the motorway and put my foot down in 4th or 5th to gain speed, the engine revs for a second or two before the actual accleration kicks in. To me it seems like something might be slipping although gears 1,2 and 3 are all ok.

Is this normal for the KA or does anyone know what the problem might be and how to fix it?

Many thanks in advance.

wilster is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Fiesta Forum | Ford kA Forum
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome