96N 1.3efi endura fiesta plz help - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Fiesta Forum | Ford kA Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Fiesta Forum | Ford kA Forum Forum for discussion of the Ford Fiesta. From US to AU discuss this little car and the mods you have done.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 02-23-2007, 11:01   #1 (permalink)
Registered User
 
fiestagrez's Avatar
 
Join Date: Feb 2007
Location: ~*~Grimsby/Cleethorpes-uk~*~
Posts: 11
96N 1.3efi endura fiesta plz help

hey there people i have recently purchased a (mk4)1996-N 1.3efi endura fiesta when i got it ,it was only doing 90mph top speed and now only doing 80mph top speed

1st thought i replaced plugs/feul filter cleaned the air filter cleaned idle valve and injection unit

2nd thought i changed the lamda sensor then i was told the cat was blocked so i have knocked out the baffles in the cat

it now picks up speed better but still wont go past 80mph

has anybody had this problem before or know what could cure it ? ? ?

many thanks
fiestagrez is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-23-2007, 14:24   #2 (permalink)
Registered User
 
fiestagrez's Avatar
 
Join Date: Feb 2007
Location: ~*~Grimsby/Cleethorpes-uk~*~
Posts: 11
Re: 96N 1.3efi endura fiesta plz help

any info much appreciated

forgot to mention when the engine is cold it doesnt struggle at all but when it warms up and slows back down

many thanks

__________________
blue fezzy 1.3i
full combat kit/alloys/decat powerflow exhaust
tints/jbl ice loads more to list

www.gloynboyz.co.uk
www.fast-n-modded.co.uk
fiestagrez is offline   Reply With Quote
Old 02-24-2007, 07:54   #3 (permalink)
Registered User
 
fiestagrez's Avatar
 
Join Date: Feb 2007
Location: ~*~Grimsby/Cleethorpes-uk~*~
Posts: 11
Re: 96N 1.3efi endura fiesta plz help

hey people i have just change the air mass sensor and the problem is solved

hope this helps anybody else with similar problem



now i can go for a or 3 lol
__________________
blue fezzy 1.3i
full combat kit/alloys/decat powerflow exhaust
tints/jbl ice loads more to list

www.gloynboyz.co.uk
www.fast-n-modded.co.uk
fiestagrez is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Fiesta Forum | Ford kA Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 21:11.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.