EAC fail 1.4 tdci fiesta - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Fiesta Forum | Ford kA Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Fiesta Forum | Ford kA Forum Forum for discussion of the Ford Fiesta. From US to AU discuss this little car and the mods you have done.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 10-29-2013, 03:10   #1 (permalink)
Registered User
 
Join Date: Oct 2013
Posts: 1
EAC fail 1.4 tdci fiesta

I recently had a fuel leak on my 2005 Fiesta 1.4 diesel.

A garage replaced the fuel injector seals, high pressure pipes, air induction hose and leak off pipe which cured the problem.

A couple of weeks later the EAC fail light started to flash whenever I accelerate unless I accelerate very gently. It then gets to a certain speed (about 10mph in first, 20mph in second etc) and won't accelerate any more with a maximum of about 50mph in fifth.

I took it to a different garage as the first doesn't have the diagnostic equipment and about ten faults were logged but the mechanic said none of them relate to the EAC problem or the that the EAC problem related to the work that was done on the injectors.

The faults logged were:
p1602-immobiliser communication
p1934-driving speed signal
p2912-reverse light switch
p0102-air mass signal (x2)
p0113-air temperature signal
p0336-crank signal
p0562-voltage supply
p0340-camshaft sensor
p0119-coolant temperature signal

He reckoned there was 'restricted engine breathing' so he separated the exhaust mounting flange but no change then he separated the catalytic converter from the turbo charge but no change then he replaced the fuel filter but still no change. He thinks the next thing to try is the fuel pump but thinks it's not worth paying for as it will cost a lot and might not solve the problem. He reckons I should just get a new car but I'm hoping there is an inexpensive cure.

Any help on how this EAC fault could be resolved would be greatly appreciated.

Thanks, Matt.
mattx029 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Fiesta Forum | Ford kA Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 20:39.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.