Feista zetec brake light prob - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Fiesta Forum | Ford kA Forum Forum for discussion of the Ford Fiesta. From US to AU discuss this little car and the mods you have done.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 12-14-05, 10:07 AM Thread Starter
Registered User
 
Join Date: Aug 2005
Posts: 1
Feista zetec brake light prob

Hi there,

I have a weird problem with my brake lights.... in that they are always on !!

When no brakes are on the central high mounted brake light is on, and the 2 tail/brake lights are brightly lit. When I tap the brake pedal the brake/tail lights go even brighter... but the central light is always on.

Any ideas if this can be an easy do-at home fix ?

Thanks
Kev

kevsnop is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Fiesta Forum | Ford kA Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome