Fiesta Heater problem - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Fiesta Forum | Ford kA Forum Forum for discussion of the Ford Fiesta. From US to AU discuss this little car and the mods you have done.

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 12-31-05, 10:01 AM
Lee Davies
Posts: n/a
Fiesta Heater problem

My parents1.3 2000 fiesta with endura engine has a non working heater. The
blower works and all pipes get hot but no heat through the vents. There are
2 pipes going into the heater but which is flow and which is return, left or
right? Is there a bleed valve for air locks and if so where is it? Thanks in

Sponsored Links
post #2 of 2 (permalink) Old 01-09-06, 05:01 AM
shadetree mx
Posts: n/a
Re: Fiesta Heater problem

Lee there is generally no valve. just the heater core is probably
clogged. you are right one is input and the other output. put your
hand on both hoses and see if one gets hot. that is the input from the
eng water. the other you need to disconnect if you can reach it if
those stupid car engineers didn't put it somewhere impossible to get
to, but I digress. and see if water is coming out of the pipe you
disconnect, if not hten your heater core is clogged and needs to be
replaced. If you are mx inclined its probably wise to get a book on
their car from local parts house. it will probably require taking the
dashboard out and steering wheel removal agin you can thank the stupid
car people for that I digress again.

Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Fiesta Forum | Ford kA Forum
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome