fiesta idle probs - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Fiesta Forum | Ford kA Forum Forum for discussion of the Ford Fiesta. From US to AU discuss this little car and the mods you have done.

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 10-20-06, 12:26 PM Thread Starter
Registered User
Join Date: Oct 2006
Posts: 1
fiesta idle probs

hiya im new to this forum and im hopeing someone with expert knowledge can sincerly help me out here. i have a 1.3 mk4 fiesta hcs efi. the problem is that when i pull up at a set of lights it starts to rev high and when i coast along it will hunt untill i come to a stop. i have replaced the iscv and the tps and also have replaced the breather hose assembly all with new parts from my local ford dealership. i have removed the throttle butterfly and heve cleaned that too. if i disconnect the iscv the engine will work ok but it lack some power. the car feels like it wants to move along on its own like as if the accelerator is sticking but i know this not to be the case. if i disconnect thge speed sensor it doesnt hunt whilst coasting. ( i dont coast just does it when i do) please someone help befor i get tottaly whacked with my car. i love the little thing and it has served me well for some time now. help.
greavey is offline  
Sponsored Links
post #2 of 2 (permalink) Old 10-20-06, 03:14 PM
Registered User
Fordtech.'s Avatar
Join Date: Apr 2003
Location: UK
Posts: 688
Re: fiesta idle probs

Could be caused by the wiring to the TPS, a bulletin was released in which the TPS and its loom had to be replaced due to interference.
Fordtech. is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Fiesta Forum | Ford kA Forum
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome