fiesta si running problems - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Fiesta Forum | Ford kA Forum Forum for discussion of the Ford Fiesta. From US to AU discuss this little car and the mods you have done.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 10-14-04, 01:12 PM Thread Starter
Registered User
 
Join Date: Oct 2004
Age: 30
Posts: 3
fiesta si running problems

Hi all, my fiesta si is running rough all the time. when u drive it, it kangaroos in all gears plus if u flip the accelerator it takes a moment to kick in. ne ideas on what this could be?? many thanks steve

SIMAN is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Fiesta Forum | Ford kA Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems after installing roller rockers (help!) NZ Windsor Tech 33 10-18-04 06:06 AM
Running problems with 95 Bird 4.6L... 85vdub Ford Thunderbird Forum 0 09-12-04 08:28 PM
Return of the fast Fiesta! Stacy94PGT Ford Fiesta Forum | Ford kA Forum 5 02-28-04 03:27 AM
Shine Through Winter In The New Ford Fiesta Silver RPO83 Ford Fiesta Forum | Ford kA Forum 0 11-25-03 06:27 PM
Fiesta rev counter problems again! timpson1 Ford Fiesta Forum | Ford kA Forum 13 04-29-03 11:16 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome