Fiesta Stalling And Juddering? - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Fiesta Forum | Ford kA Forum Forum for discussion of the Ford Fiesta. From US to AU discuss this little car and the mods you have done.

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 06-12-05, 01:53 AM Thread Starter
Registered User
Join Date: May 2005
Posts: 14
Fiesta Stalling And Juddering?

Hi, i have a mk3 fiesta Si 1995 1.4, its a lovely car with only 54k on the clock, but unfortunately it does like to stall :). The problem i think lies in the mass air flow sensor, as when i plug the clip in the sensor (and the engine is idleing as normal) the engine after about 2 seconds just starts juddering up and down, until it gets to the point where it just stalls, if you unclip it, then the car idles normally, Although this sensor is ment to be plugged in! i dont know what the problem is need help guys!!!!

I have been using the car without the sensor at the moment, but i dont think the car likes it, when coming to a stop and taking my foot off the accelerator the car only sometimes judders a bit, and sometimes even when im going along at bout 30 in 3rd!

Any ideas???

kevinsmbuk is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Fiesta Forum | Ford kA Forum
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome