Fiesta Zetec 1.25, RPM not going down Normally - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
» Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Fiesta Forum | Ford kA Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Fiesta Forum | Ford kA Forum Forum for discussion of the Ford Fiesta. From US to AU discuss this little car and the mods you have done.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 04-20-2006, 03:50   #1 (permalink)
Registered User
 
Join Date: Apr 2006
Posts: 1
Fiesta Zetec 1.25, RPM not going down Normally

Before I start, excuse me, my language because English is not my first language.
I have a problem with my Fiesta engine Zetec 1.25L (16V) 98.
The problem is that the RMP’s goes up to 4-5K and sty there on driving. When the car stops the RPM goes back to normal…
I’ll describe it…
If I start (first gear) and change it to second gear, in neutral the RPM goes up… So on every other Gear… If I tap the gas it wont go down, and there is a feeling that the engine is pulling the car ahead. Only when the car stops the RPM goes back to normal idle.
I did an experiment, I drove the car on a escarpment, first gear the second and the pull it to neutral. The RPM goes up to 4-5K…
Then the street went up, and the car stopped on it’s own. The RPM went back to normal… So there is no connection to the breaks, booster etc…
Also If I drive and press the gas “to the metal” the engine wont accelerate and there is a “suffocation” noise… No meter what gear.

This is not the throttle cable, on standing the RPM goes back to normal immodestly.

Any ideas?
Gili
redbaron is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Fiesta Forum | Ford kA Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 14:25.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.