Ford Fiesta Optima -93, several problems - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Fiesta Forum | Ford kA Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Fiesta Forum | Ford kA Forum Forum for discussion of the Ford Fiesta. From US to AU discuss this little car and the mods you have done.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 09-23-2007, 15:04   #1 (permalink)
Registered User
 
Join Date: Sep 2007
Posts: 1
Ford Fiesta Optima -93, several problems

Hi all, my first post here

need some help on some problems...

When I'm driving at speeds around 50km/h (ca 30 mph) I get this cyclic, repeating, humming (low base) noise from the rear axle, anyone have a clue to what might be causing this??

another problem...more serious
Last week when braking the pedal started to feel kind of mushy, spongy (air?) and the brakes did not perform, THEN it would not work at all, the pedal went all down and would only use the one system (rear left, front right) and there was some dripping coming from the centre of the car (visible on the ground under the car) obvious leeking of course, BUT the mechanic at the shop cannot locate where the leaking is coming from !!! what is going on here, please anyone ?!
adder is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-24-2007, 12:07   #2 (permalink)
Registered User
 
Fordtech.'s Avatar
 
Join Date: Apr 2003
Location: UK
Posts: 688
Re: Ford Fiesta Optima -93, several problems

1/ probable wheel bearing;
2/ sounds like a brake pipe corroded or loose.
Fordtech. is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Fiesta Forum | Ford kA Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 01:55.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.