Ford Fiesta Optima -93, several problems - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Fiesta Forum | Ford kA Forum Forum for discussion of the Ford Fiesta. From US to AU discuss this little car and the mods you have done.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 09-23-07, 02:04 PM Thread Starter
Registered User
 
Join Date: Sep 2007
Posts: 1
Ford Fiesta Optima -93, several problems

Hi all, my first post here

need some help on some problems...

When I'm driving at speeds around 50km/h (ca 30 mph) I get this cyclic, repeating, humming (low base) noise from the rear axle, anyone have a clue to what might be causing this??

another problem...more serious
Last week when braking the pedal started to feel kind of mushy, spongy (air?) and the brakes did not perform, THEN it would not work at all, the pedal went all down and would only use the one system (rear left, front right) and there was some dripping coming from the centre of the car (visible on the ground under the car) obvious leeking of course, BUT the mechanic at the shop cannot locate where the leaking is coming from !!! what is going on here, please anyone ?!

adder is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 09-24-07, 11:07 AM
Registered User
 
Fordtech.'s Avatar
 
Join Date: Apr 2003
Location: UK
Posts: 687
Re: Ford Fiesta Optima -93, several problems

1/ probable wheel bearing;
2/ sounds like a brake pipe corroded or loose.
Fordtech. is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Fiesta Forum | Ford kA Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome