Ford KA PCM failure due to water ingress - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
» Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Fiesta Forum | Ford kA Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Fiesta Forum | Ford kA Forum Forum for discussion of the Ford Fiesta. From US to AU discuss this little car and the mods you have done.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 05-28-2006, 12:00   #1 (permalink)
Registered User
 
Join Date: May 2006
Posts: 3
Ford KA PCM failure due to water ingress

We have a 3 year KA whch at 2years had a failure to charge and erratic running due to a fault dignosed by ford dealer as corrosin to the PCK connection due to water ingess. They diagnosed leak wa via the front windscreen and repair costs were considerable. Ford warrantee refused and we had to pay but on connecting ford they eventually contributed 50% towards the cost of PCM but not the cost of waterleak rectification.
10 months later the same fault appeared and another new PCM was required. Enquiries to ford confirmed unit was covered by warrantee but as water leak was diagnosed by the same ford dealer as coming from another surse, ie via the wiring loom insulation fault was again now covered by ford.
Considerable correspondence has done nothing and the total cost of repair £1100! Ford say this is not a general problem and iif we want to take matters further we should do so in con*****tion with the ford dealeras we questioned the original diagnosis. Will any other ka users who have water ingress or simular problems with the PCM please let me know. Thank Doug
dougalgrove is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-18-2008, 10:54   #2 (permalink)
Registered User
 
Join Date: Feb 2008
Posts: 1
confused Re: Ford KA PCM failure due to water ingress

I have just experienced a very similar scenario:

multiple misfire problems followed by failure to start. Replacement of coil pack and spark plugs did not cure the problem. Further investigation revealed that water ingress had damaged the PCU beyond repair. New PCU unit plus labour to remove dash etc resulted in a bill for £791.

The dealer did ask Ford if they would contribute as this was the result of a possible design fault. They told me that Ford were not interested due to the age of the car. Our KA was purchased new in 2003 (5 years old)
rock doctor is offline   Reply With Quote
Old 02-25-2008, 15:27   #3 (permalink)
Registered User
 
Join Date: Oct 2007
Posts: 30
Re: Ford KA PCM failure due to water ingress

i take it by pcm you mean the ECU, i had a similar problem on my 98 fiesta had a really weird problem where it would rev to about 4.5k on the rev counter when you approached a junction after pushed the clutch to the floor.
i changed a couple sensors on the car which didnt fix the problem to it went in to my main dealer they couldnt gind the problem after a couple of hours labour and told me that the car need a new ECU and then tried to buy the car off me of which at the time it was not mine to sell and i didnt even let them make a offer.
anyway to cut long story short all the car needed was a reset of the ECU and the original fault has gone away also the new fault that my ex main dealer created which made the car undeliverable.
i used think that terms of knowledge main dealer was the best at the top, next joe bloggs garage, then people like me who tinker with cars since my running with ford ive changed this to joe blogs garage defiantly at the top then people like me who tinker with cars in there spare time then right at the bottom ford main dealer who in at least my case employee muppets
__________________
[img]
nick_rs2k is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Fiesta Forum | Ford kA Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 07:28.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.