Horn problem - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Fiesta Forum | Ford kA Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Fiesta Forum | Ford kA Forum Forum for discussion of the Ford Fiesta. From US to AU discuss this little car and the mods you have done.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 01-15-2005, 03:53   #1 (permalink)
Registered User
 
Join Date: Jan 2005
Posts: 2
roll Horn problem

I have a 2000 X reg Ford Ka and my horn is not working. When I checked the owner's manual to see which fuse it was it says that the same fuse runs the horn and hazard flashers. My hazard flashers are still working so I figure it can't be the fuse.

Any ideas where the problem is?

(If this is a really stupid question be gentle with me! I'm a woman and as can be expected have no idea about cars!)
madmish is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-15-2005, 04:55   #2 (permalink)
Registered User
 
Join Date: Oct 2004
Location: Newcastle
Age: 28
Posts: 278
Re: Horn problem

Well that pretty much rules out the fuse then, could be a couple of the wires that connect the horn, honestly unless you love ripping bits of your ford out to have a closer look then i suggest you just take your car to your local ford service department and tell them whats happening and ask them to check it out, if you get a decent mechanic or your still under some sort of parts warranty then you might get out of the situation without paying a cent.
Good luck with it :)
Mitch
__________________
Spinning first .... Chirping second ... and NEAAAAARLY chirping third. Fiesta is the word. Its more than just a party on wheels.
Mitch_lx is offline   Reply With Quote
Old 01-20-2005, 08:48   #3 (permalink)
Registered User
 
Join Date: Jan 2005
Posts: 25
Re: Horn problem

Its probably the two wires that come out of the wiring loom into the horn.. If not I guess it could be the horn thats died a death like ^^^ says, take it to a ford dealer; cheaper and easier that way (cheaper if you break something else!!!)


James
jammapic is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Fiesta Forum | Ford kA Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
87 Bronco-Fusible link problem, maybe? HELP ladyferricher Ford Bronco Forum 1 09-14-2004 21:16
Problem with alternator belt Blindin Inline 6 Tech 1 08-22-2004 16:59
Horn not working-> FIXED!!!! (follows on from horn pad contact thingo thread) Rollin Australian Falcons 0 08-22-2004 06:43
AU XR8 Series 1 ignition lead problem supernugget Windsor Tech 12 07-19-2004 04:16
Steering/wheel alignment problem mike98AUXR6VCT Suspension | Wheels&Tires | Brakes 10 04-23-2004 04:33

Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 00:46.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.