Installed footwell lights - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Fiesta Forum | Ford kA Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Fiesta Forum | Ford kA Forum Forum for discussion of the Ford Fiesta. From US to AU discuss this little car and the mods you have done.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 10-24-2007, 06:47   #1 (permalink)
Registered User
 
Join Date: Oct 2007
Posts: 1
Installed footwell lights

I done my DIY install for Footwell lighting in my Fiesta, and now, the car won't start.

I tested it by touching the pos/neg of the wires onto the interior light switch and I believe I blew the fuse as the light stopped working.

Now my car won't start, all I get when I turn the key is the regular oil light & handbrake light, but no battery light like usual. I can use the radio and most other things however, such as headlights.

When I try and turn it over to start the engine, nothing happens.

Can anybody help me? I am seriously desperate. I haven't got another key to try that if the key has lost its code until later on when my girlfriend gets back.

Please help?! I'm desperate, heh. Thanks guys.

Edit: It's a Fiesta Mark 6, the new shape one. The guide I used for install :

Board Message
dLockers is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-24-2007, 15:26   #2 (permalink)
Registered User
 
Join Date: Oct 2007
Posts: 30
Re: Installed footwell lights

i dont know the answer but if it was my car i would be looking at the main fuses (not the little blade fuses) i know on my cars the main fuses are under the bonnet and not in the fuse box which is in the car.
ive never blow one of them personally but this is what i would look at if i couldn't find a fault with the normal fuse box fuses.
worth a check.
nick_rs2k is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Fiesta Forum | Ford kA Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 15:28.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.