Ka power problem - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Fiesta Forum | Ford kA Forum Forum for discussion of the Ford Fiesta. From US to AU discuss this little car and the mods you have done.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 12-30-05, 04:55 AM Thread Starter
Registered User
 
Join Date: Dec 2005
Posts: 2
frown Ka power problem

Hi, my wife has a T reg Ka that has gradually lost power over the last few weeks. The Ka will only go about 15 mph up hills and needs to be dropped down to 1st or 2nd gear. I have checked the obvious but cannot find the cause. Does anyone have any ideas as to what the problem may be?

Thanks in advance.
a_sheldon is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 01-02-06, 05:02 PM
Registered User
 
eMPee's Avatar
 
Join Date: May 2005
Posts: 32
Re: Ka power problem

try looking in the european ford owners club thread. The KA is from europe so hopefully u can find your answer there.

'02 BA XL c/chassis manual ute, Blue Pearl factory, 17' Akuza's, 20% tints, XR6T Snorkle, XR8 2nd CAI, BMC Filter, HPC Advance Headers, 2.5" exhaust, Alpine TypeR 5x7's, 2 X Alpine amps, Rockford 10" killer audio
eMPee is offline  
post #3 of 5 (permalink) Old 01-03-06, 02:38 AM Thread Starter
Registered User
 
Join Date: Dec 2005
Posts: 2
Re: Ka power problem

Thanks eMPee I will have a look today.
a_sheldon is offline  
post #4 of 5 (permalink) Old 01-03-06, 12:34 PM
Registered User
 
Join Date: Jan 2006
Location: UK
Age: 29
Posts: 5
Re: Ka power problem

Not a slipping clutch is it?
Martyn999 is offline  
post #5 of 5 (permalink) Old 01-03-06, 11:23 PM
Registered User
 
eMPee's Avatar
 
Join Date: May 2005
Posts: 32
Re: Ka power problem

i just checked out the euro ford club, i hadn't seen it before. sorry but there isn't much info there at all. it wasn't what i thought it was. My girlfriend has a KA and it makes a few noises here and there, but havent had massive loss of power like u have

'02 BA XL c/chassis manual ute, Blue Pearl factory, 17' Akuza's, 20% tints, XR6T Snorkle, XR8 2nd CAI, BMC Filter, HPC Advance Headers, 2.5" exhaust, Alpine TypeR 5x7's, 2 X Alpine amps, Rockford 10" killer audio
eMPee is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Fiesta Forum | Ford kA Forum
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome