No heating... fiesta 1.25 LX "99" - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Fiesta Forum | Ford kA Forum Forum for discussion of the Ford Fiesta. From US to AU discuss this little car and the mods you have done.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 10-16-05, 07:12 PM Thread Starter
Registered User
 
Join Date: Oct 2005
Posts: 1
No heating... fiesta 1.25 LX "99"

I currently experinces some problems on my heater fan... Its aint come out hot air at all, only has cold air all the times either put on cold or hot temp. My temp gauge is fines, always in the midway when the car r warm but just had no hot heat inside the car... Can some 1 help?

thanh is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 11-07-05, 06:43 AM
Registered User
 
Join Date: Nov 2005
Posts: 1
Re: No heating... fiesta 1.25 LX "99"

Quote:
Originally Posted by thanh
I currently experinces some problems on my heater fan... Its aint come out hot air at all, only has cold air all the times either put on cold or hot temp. My temp gauge is fines, always in the midway when the car r warm but just had no hot heat inside the car... Can some 1 help?

Try look at your heater matrix, it may need flushing out.
PBDazza is offline  
post #3 of 3 (permalink) Old 11-09-05, 06:21 AM
Registered User
 
Join Date: Nov 2005
Posts: 2
Re: No heating... fiesta 1.25 LX "99"

Have a look if fuse number 2 (7.5A) on the main fuse board has blown.

Second from the left on the bottom row.

The owners manual says it supplies the clock and interior lights.

Well it also supplies the heating and aircon!

I've just sorted my heating problem by replacing that fuse.

Hope this helps.

76zed900.
76zed900 is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Fiesta Forum | Ford kA Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome