Problems - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Fiesta Forum | Ford kA Forum Forum for discussion of the Ford Fiesta. From US to AU discuss this little car and the mods you have done.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 01-24-09, 05:25 AM Thread Starter
Registered User
 
Join Date: Jan 2009
Posts: 1
Problems

Hi,

I have a 1997 1.1 fiesta lx, iv had it about 2 yrs, its had a brand new engine costing £1200, and its been fine since then but its recently been playing up, it will start fine even in the freezing cold weather and run for about 3 day then all of a sudden the battery will be flat and wont start, ive changed the battery, alternator, starter motor, filter, plugs n leads, when i changed the filter it was quite gunky and oily inside?? I also took it to an auto electrictian and he thought he had solved it, he replaced something costing £125 but now the problem has started again??

PLEASE HELP

Thanks Robert

robert_fiesta is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 01-25-09, 02:09 PM
Registered User
 
Join Date: May 2008
Posts: 2
Re: Problems

Whats is your problem ?
victor_vip is offline  
post #3 of 4 (permalink) Old 01-27-09, 01:34 PM
Moderators
 
R.S.LOGAN's Avatar
 
Join Date: Apr 2007
Location: Scotland
Posts: 14,324
Re: Problems

Could return to electrician who charged you £125 and tell him fault still there and ask him to test if anything draining battery . Could also get alternator output tested and battery for any weak cells , simple tests .
R.S.LOGAN is offline  
post #4 of 4 (permalink) Old 02-22-09, 01:13 PM
Registered User
 
Join Date: Feb 2009
Posts: 26
Re: Problems

yes take it back to him! and find out for me what the f--k cost £125 thanks
dave6068 is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Fiesta Forum | Ford kA Forum
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome