Thermostat on w reg 1.25 fiesta - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Fiesta Forum | Ford kA Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Fiesta Forum | Ford kA Forum Forum for discussion of the Ford Fiesta. From US to AU discuss this little car and the mods you have done.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 10-11-2006, 06:41   #1 (permalink)
Registered User
 
Join Date: Oct 2006
Posts: 2
Thermostat on w reg 1.25 fiesta

Looks like the thermostat on my W reg Ford Fiesta has gone.

Is this an easy job to do?

Looked in the Hayes book and it says the system will need to be drained - which i would be able to do. It then also says that the alternator will need to be removed. Is this correct? The Hayes book says changing the thermostat is a 2 spanner job but removing the alternator is a 4 spanner job.

Any help would be much appreciated.

Many thanks

Paul
fallows is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-11-2006, 15:57   #2 (permalink)
Registered User
 
Join Date: Oct 2006
Posts: 8
Re: Thermostat on w reg 1.25 fiesta

I have recently had a problem with overheating on my 1.25, and i think it turned out to be just some trapped air in the system. It was giving all the symptoms of a faulty thermostat but it cleared up after i had a valve for the interior heaters replaced. so there is a chance it may be just trapped air, but from what i read in the haynes manual it looks pretty easy to get the altenator out. just follow the steps (obviously ) and it should be fine.

if you have any doubts, see what a local garage will charge to replace the thermostat... shouldnt be too much.
fullyinsane is offline   Reply With Quote
Old 10-12-2006, 01:37   #3 (permalink)
Registered User
 
Join Date: Oct 2006
Posts: 2
Re: Thermostat on w reg 1.25 fiesta

The heaters in the car are now also not working. I was driving along and hot air was coming out then for no reason they just started to give our cold air.

Could this be because of the heater control valve?

Would it be best to change this heater control valve first to see if it solves both problems?

Many thanks

Paul
fallows is offline   Reply With Quote
Old 10-12-2006, 13:45   #4 (permalink)
Registered User
 
Fordtech.'s Avatar
 
Join Date: Apr 2003
Location: UK
Posts: 688
Re: Thermostat on w reg 1.25 fiesta

Is this why you thought the thermostat had gone, because the heater went cold? If so, it more than likely is the heater valve if the temp gauge reads normal.
Fordtech. is offline   Reply With Quote
Old 10-13-2006, 07:38   #5 (permalink)
Registered User
 
Join Date: Oct 2006
Posts: 8
Re: Thermostat on w reg 1.25 fiesta

If the temp is reading normal then it's an issue with the valve (most likely) or the air distribution flaps.

Regards - J
johnb80 is offline   Reply With Quote
Old 11-06-2006, 11:22   #6 (permalink)
Registered User
 
Carlos Coysh's Avatar
 
Join Date: Nov 2006
Posts: 12
Re: Thermostat on w reg 1.25 fiesta

Hey i hope people are still able to help with the heater control valve issue, my fiesta 1.25 has absolutely no heatng at all, now this time last year it went also and i replaced it with a new one, and it all worked fine, a year on and that one has gone also, so again i got a new one and fitted it, but this time there is no response and the prob isn't fixed, terrible time of year for it to mess up lol, but i was thinkin it could be the thermo, as the heat guage on the dash is normal but no heat is being pumped into the car, i mean i checked the pipes the two pipes going into the valve are hot and the left hand pipe coming out is also hot, and obviously the right one coming out of the valve is cold, which as a basic check seems to be all good, can anyone suggest anything i can do to sort this out, i'm freezing guys lol... cheers
Carlos Coysh is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Fiesta Forum | Ford kA Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 17:35.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.