1990 EA falcon runs rough on startup - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Australian Ford's Discussion > Australian Falcons
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Australian Falcons Discuss the australian born and bred models here. Includes the 80's 90's and present day Falcons offered by Ford Oz.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 05-12-2011, 05:39   #1 (permalink)
Registered User
 
Join Date: May 2011
Posts: 2
1990 EA falcon runs rough on startup

My ea falcon in the past would start but when running on E it would slowly put out i think this was from all the crap at the bottom of the tank so i would put gas in and it would fix it straight away. now its gotten to the stage where it cuts out almost straight away if i dont rev. and even when im driving it feels as if the throttle is cutting in and out and only getting bunny hop throttles but its moving at around 50kms and iv got it on full throttle?

Iv been told its something to do with dirty injectors or filters.
jakeheke is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-12-2011, 07:17   #2 (permalink)
Moderators
 
Join Date: Apr 2007
Location: Scotland
Posts: 11,212
Re: 1990 EA falcon runs rough on startup

Could check the basics like plugs , ignition leads , fuel filter and also engine coolant temp sensor .
R.S.LOGAN is offline   Reply With Quote
Old 05-12-2011, 17:21   #3 (permalink)
Registered User
 
Join Date: May 2011
Posts: 2
Re: 1990 EA falcon runs rough on startup

could you lead in the direction of how to check the fuel filter?? im not very mechanically minded.
jakeheke is offline   Reply With Quote
Old 05-17-2011, 04:56   #4 (permalink)
300+rwkw DC LTD Member
 
LTDHO's Avatar
 
Join Date: Jul 2001
Location: Melbourne, Vic
Age: 40
Posts: 1,620
Re: 1990 EA falcon runs rough on startup

The 1st filter is on the pickup mounted on the pump.
2nd one is inline under the body, above the diff, mounted the chassis.

There is a good chance that the reg and injectors are fowled too.
__________________
LTDHO
Power by Herrod 185rwkw
Power by me 313.6rwkw
Stereo by ///Alpine
LTDHO is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Australian Ford's Discussion > Australian Falcons



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 17:21.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.