Anyone else having a good run? - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Australian Ford's Discussion > Australian Falcons
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Australian Falcons Discuss the australian born and bred models here. Includes the 80's 90's and present day Falcons offered by Ford Oz.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 12-16-2004, 05:36   #1 (permalink)
Insignifcant Other
 
Join Date: Sep 2004
Location: Perth
Age: 28
Posts: 28
Anyone else having a good run?

I've had my xt for just under six months, bought used (make 2003). So far i've yet to experience anything major, only a little bit of oil leaking from the sump gasket. This forum has shown me the dissapointment in alot of the ford owners.

has anyone else had a good run with theirs?
__________________
2003 BA XT, Silhouette, 18" AMG Quakes, Kings Supalows. Carbon 3M ScotchTint, Jan '06 - CAPA flash tune
Multitronic is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-16-2004, 06:18   #2 (permalink)
EA Dumped on its arse
 
gtfalcon351's Avatar
 
Join Date: Feb 2004
Location: Melbourne
Age: 29
Posts: 169
Re: Anyone else having a good run?

Dads had his XT for about a year now and the only problems weve had were that the Throttle body was gunked up with crap from the PCV which was causing hard starting,

also we noticed it was losing about half a litre of coolant every 2 weeks and we found it was caused by the steel pipe which fits into the back of the water pump leaking where the o-ring goes into the back of the pump, Ford have a little bracket that bolts into the back of the pump and holds this pipe into the pump body more firmly that we still have to get installed under warranty
__________________
1991 Peugeot 405 Mi16 with 160Hp Stock

1988 EA Falcon CFI Slug
gtfalcon351 is offline   Reply With Quote
Old 12-18-2004, 05:58   #3 (permalink)
Registered User
 
Join Date: Nov 2004
Location: south coast nsw
Age: 38
Posts: 27
Re: Anyone else having a good run?

yeh mine has gone well, XR8,38000 km. only minor things, a rattle that annoyed me and seatbelts that gunked up and would not retract.
i know a few others with BA's and none of them have anything serious to report either.
CBYOOT is offline   Reply With Quote
Old 12-18-2004, 07:06   #4 (permalink)
Dev 5 Mutant
 
loxxr6's Avatar
 
Join Date: May 2004
Location: Sydney
Posts: 1,383
Re: Anyone else having a good run?

I've had my xt for just under six months, bought used (make 2003). So far i've yet to experience anything major, only a little bit of oil leaking from the sump gasket. This forum has shown me the dissapointment in alot of the ford owners.

has anyone else had a good run with theirs ?



Its actually quite refreshing to see someone post something positive about their car (thats not performance related) rather than the usual problems. Yeah I know if build quality was better we'd all be happy....

While I don't own a BA I can honestly say I've had an awesome run with the AU. All the problems I have had have been self inflicted - destroying clutch, bald tyres etc.
__________________
Proud TQE Operator
1999 Black Manual AU XR6HP
Unichip equipped by Autotech Engineering, Granville
Cam install by Crescent Motorsport, Liverpool

Dyno

Timeslip
loxxr6 is offline   Reply With Quote
Old 12-18-2004, 11:12   #5 (permalink)
Registered User
 
crank's Avatar
 
Join Date: Nov 2004
Age: 35
Posts: 74
Re: Anyone else having a good run?

Quote:
Originally Posted by CBYOOT
yeh mine has gone well, XR8,38000 km. only minor things, a rattle that annoyed me and seatbelts that gunked up and would not retract.
i know a few others with BA's and none of them have anything serious to report either.
What was the cause of the rattle that you had?

16,000ks on my XR8 ute and besides a front suspension rattle when it hits a sharp edge bump everything has been good.

I've had the rattle in twice and the first time was told it was the sump guard missing 2 bolts which they replaced. That made no difference. Then i was told the steering rack was a bit loose and they tightened it but that's made no difference either.

Only fault i've had and it doesn't seem to affect anything except make a noise so i'm happy with the ute.
crank is offline   Reply With Quote
Old 12-18-2004, 11:27   #6 (permalink)
Just give me an excuse...
 
Night_Lurker's Avatar
 
Join Date: Oct 2002
Location: struct melbourne hallam;
Age: 34
Posts: 3,949
Re: Anyone else having a good run?

XT here, had it just over 2 years. Had some small issues to begin with (coolant leak and software error) but they are minor. All good so far.
__________________
Truly the deepest kiss one can feel, and the one most sought after, is the one you will not survive....
Night_Lurker is offline   Reply With Quote
Old 12-18-2004, 15:26   #7 (permalink)
Resident geek freak
 
jemmex's Avatar
 
Join Date: Sep 2002
Location: permanetly lost NSW
Age: 48
Posts: 935
Re: Anyone else having a good run?

12 months, 48,000km
what to report?
A few small rattles (i found and fixed most of them myself), had 1 stereo speaker replaced, biggest prob was a tranny prob, where sometimes you coulnt get it in D or P, dealer fixed it in 10 mins, said it was a loose bit of trim or cable, baulking the lever itself.

God I hope im not giving it the kiss of death, but so far it has never let me down. Its a f..king fantastic car.

----------
"Lightening Strike" XTsports, Barra 182 auto, 17" 7-spoke alloys, "SR" body kit & spoiler, max legal tinted glass, cruise control, power windows all round, towpack, premium sound, 4 mudspats, scuff plate inserts, boot liner, phone presenter, mp3 audio input, slimline NSW white numberplates

Pix here BA XT plus 17" alloys, sports suspension & body kit
jemmex is offline   Reply With Quote
Old 12-18-2004, 16:06   #8 (permalink)
At the 3FB Cheese Wheel
 
Jamie XR6's Avatar
 
Join Date: Jan 2002
Location: Sydney
Age: 45
Posts: 3,582
Re: Anyone else having a good run?

I've racked up 17000 in 12 months and have only had a melted cable from the heat off the turbo. Ford fixed it in a couple of hours and it was good as new.

Apart from that, I've got an annoying squeak where the plastic notice on the passenger window visor rubs on the roof lining. That's easy fixed though, I just put a cloth between it an the roof lining.

It's a great car and I love it.
__________________
My Car's Website: Click Here
Sept 03 BA XR6 Turbo, Silhouette, T5, APS Unichip, BPT short shifter & Momo bits, FPV pedals, Custom Leather, 18" Wheels, PBR sports calipers, Window Tint, Typhoon CAI, Side stripes.
Jamie XR6 is offline   Reply With Quote
Old 12-18-2004, 21:58   #9 (permalink)
Registered User
 
Bearman's Avatar
 
Join Date: Feb 2003
Location: Outer East, Melbourne, Vic
Posts: 581
Re: Anyone else having a good run?

BA XR6 NA bought second hand in August at 25,000km. Now done 32,000km.

Not a worry in the world!! Occasionally a rattle when the car is stopped at a red light or whatever I get a tinny rattle from the engine bay. When I get off the brakes it disappears and returns when I get back on the brakes. No rattle when the car is moving. No biggie, does not annoy me in fact I haven't heard it for a while now.

30,000km service at Etheridge Ford was no probs at all, scored 2 brand new tyres under warranty due to sidewall cracks. Apparently there was a bad batch out of Dunlop.

The car is great!! So far so good with the dealer as well.
__________________
BA XR6 NA Mercury Silver (daily drive)
XC Fairmont Coupe (sunday cruiser)
www.fordcoupeclub.org.au
Bearman is offline   Reply With Quote
Old 12-19-2004, 00:42   #10 (permalink)
Registered User
 
Join Date: Sep 2003
Posts: 139
roll Re: Anyone else having a good run?

Ive had the o-ring on the back of the water pump replaced twice now on my au2 ute(2000).You think ford would of sorted it out by now.
CLARKEY is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Australian Ford's Discussion > Australian Falcons



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Looking for a ford dealer with a good rep gary mclachlan Ford Ute Forum 7 07-08-2004 17:59
Good Looks, EA-ED vs EF-EL bonka E-Series Falcons 47 07-03-2004 05:04
Is this a good idea? skip The Pub 7 04-30-2003 04:00
FPR have a good chance at Eastern Creek? JamesM Ford Racing Across the Globe 8 04-16-2003 03:03

Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 04:42.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.