AU falcon issues (speedo and off idle performance) - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Australian Falcons Discuss the australian born and bred models here. Includes the 80's 90's and present day Falcons offered by Ford Oz.

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 06-22-04, 11:25 PM Thread Starter
no ute, XR8 on order
Join Date: Jul 2002
Location: Hobart
Posts: 32
AU falcon issues (speedo and off idle performance)

Hi All,

in the last couple of days some oddness has crept in to my AU (Nov 99 build, Auto,I6) XLS ute, its done 3000km since its last service and has been faultless until now.


2 things have started, the car can be idling in park or neutral and (especially when its cold and idling higher) the speedo starts to register anything up to 20km/h (which makes the park brake warning start)

the other is that the off idle performance has developed a stutter for 1 or 2 seconds before smoothing out and accellerating.

anyone know what might be causing this?


AUUTE is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Australian Ford's Discussion > Australian Falcons
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome