BA Ute lost power on the highway - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Australian Falcons Discuss the australian born and bred models here. Includes the 80's 90's and present day Falcons offered by Ford Oz.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 03-10-05, 09:42 PM Thread Starter
AU3 BT1
 
scruba's Avatar
 
Join Date: Jul 2003
Location: North Brisbane
Age: 40
Posts: 199
Arrow BA Ute lost power on the highway

Phoned Ford and they said it is happening a lot at the moment with the BAs although wouldn't elaberate any further.

Has this happened to anyone else? If so what was the problem?


Our new ride - Narooma Blue Forte BT1 06/2002 AU3
My Falcon is here
AU1 Fairmont Galaxy Blue (Company Car)
Brisbane Car Detailers We share your passion for cars
scruba is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 03-10-05, 09:58 PM
Registered User
 
Join Date: Oct 2004
Age: 43
Posts: 54
Re: BA Ute lost power on the highway

Quote:
Originally Posted by scruba
Phoned Ford and they said it is happening a lot at the moment with the BAs although wouldn't elaberate any further.

Has this happened to anyone else? If so what was the problem?

did it feel like you were down a cylinder or two and the car ran rough... if so this is overboost..... no real fix as far as im aware... ford say they have a fix but am yet to hear of any real success stories.... This happened to me once when it was cold weather... am waiting for winter to see if it happens agagin.
jetute is offline  
post #3 of 5 (permalink) Old 03-11-05, 03:24 AM Thread Starter
AU3 BT1
 
scruba's Avatar
 
Join Date: Jul 2003
Location: North Brisbane
Age: 40
Posts: 199
Re: BA Ute lost power on the highway

Should have mentioned in my post that it is N/A 6

Our new ride - Narooma Blue Forte BT1 06/2002 AU3
My Falcon is here
AU1 Fairmont Galaxy Blue (Company Car)
Brisbane Car Detailers We share your passion for cars
scruba is offline  
post #4 of 5 (permalink) Old 03-11-05, 03:25 AM Thread Starter
AU3 BT1
 
scruba's Avatar
 
Join Date: Jul 2003
Location: North Brisbane
Age: 40
Posts: 199
Re: BA Ute lost power on the highway

Should have mentioned in my post that it is N/A 6

I wasn't driving it but the driver said that there was no warning...just lost power.

Our new ride - Narooma Blue Forte BT1 06/2002 AU3
My Falcon is here
AU1 Fairmont Galaxy Blue (Company Car)
Brisbane Car Detailers We share your passion for cars
scruba is offline  
post #5 of 5 (permalink) Old 03-16-05, 12:59 AM Thread Starter
AU3 BT1
 
scruba's Avatar
 
Join Date: Jul 2003
Location: North Brisbane
Age: 40
Posts: 199
Re: BA Ute lost power on the highway

turned out to be the electronic throttle relay

Our new ride - Narooma Blue Forte BT1 06/2002 AU3
My Falcon is here
AU1 Fairmont Galaxy Blue (Company Car)
Brisbane Car Detailers We share your passion for cars
scruba is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Australian Ford's Discussion > Australian Falcons


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
ba xls 220 kw auto ute or ba xr 6 ute gregff Ford Ute Forum 7 04-27-04 06:46 PM
AUS: Tough Truck On Show In Sydney RPO83 Ford Worldwide News 0 10-15-03 06:05 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome