EF thermo fan problem - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Australian Ford's Discussion > Australian Falcons
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Australian Falcons Discuss the australian born and bred models here. Includes the 80's 90's and present day Falcons offered by Ford Oz.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 12-23-2004, 05:57   #1 (permalink)
Registered User
 
Join Date: Dec 2004
Age: 40
Posts: 1
EF thermo fan problem

My EF XR8 seems to have a problem with airflow to the radiator, and I believe I have tracked the problem to the thermo fans. The fans are working, but I don't think they are switching to high speed.

I've checked the relays and can't fault them. If I force the relay output I get the fans into high speed. However, if I set the a/c to max and interior fan on boost, the thermos will not go into high speed (and these conditions should bring on high speed).

Anyone got any ideas on this?

Cheers,

Brett
TheInterceptor is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Australian Ford's Discussion > Australian Falcons



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Independent thermo control on EF - neccesary? back2thefutura Interior | Electrical | ECU 11 08-11-2004 03:39
Thermostat/cooling problem mockymockva Ford Probe Forum | Mazda MX6 Forum 0 05-10-2004 06:07
EF Airbox into EA 3.9L and stnd manifold Dellboy999 Inline 6 Tech 12 07-08-2003 15:20
EF gearbox problem adamvw Trans | Driveline 7 04-14-2003 04:18
EF V8 Ping...(Long) Shark General Tech 30 07-27-2002 14:55

Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 15:24.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.