ford 2000 futura, cant find forum for this make need ur help please read my problem! - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Australian Ford's Discussion > Australian Falcons
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Australian Falcons Discuss the australian born and bred models here. Includes the 80's 90's and present day Falcons offered by Ford Oz.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 01-18-2009, 02:34   #1 (permalink)
Registered User
 
Join Date: Jan 2009
Posts: 3
frown ford 2000 futura, cant find forum for this make need ur help please read my problem!

I have a ford falcon futura station wagon 2000 model.. I drove my car working fine stopped for approx half hr, returned to car and had no blinkers or signs of ever having blinkers no noise sound nor lights to indicate etc, so on investigation discovered fuse blown, replaced fuse upon turning car on instantly blew before turning blinkers on? so retired more fuses same thing, so replaces flasher - relay not the problem.. still same thing occurring. Checked all light bulbs and sockets and wiring close to sockets all fine no signs of damage or breakage etc.. Have no clue as to what else this might be any help into this matter would be appreciated!

Last edited by angie1982; 01-18-2009 at 02:41. Reason: spelling mistake
angie1982 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-19-2009, 00:10   #2 (permalink)
Registered User
 
gl351xd's Avatar
 
Join Date: Apr 2004
Location: yarrawonga northen victoria
Posts: 90
Re: ford 2000 futura, cant find forum for this make need ur help please read my probl

Has it got a trailer plug ? If so try disconnecting the wires there . I got paint in the plug on mine once and it kept blowing the fuse . Just a thought . Cheers Ken
gl351xd is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Australian Ford's Discussion > Australian Falcons



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 21:04.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.