Help needed with XR6 Ba Mk2 - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
» Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Australian Ford's Discussion > Australian Falcons
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Australian Falcons Discuss the australian born and bred models here. Includes the 80's 90's and present day Falcons offered by Ford Oz.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 05-03-2005, 03:48   #1 (permalink)
Registered User
 
1000's Avatar
 
Join Date: Mar 2005
Posts: 95
Help needed with XR6 Ba Mk2

Hey all.

I've had the XR 6 for around two weeks now and absolutely love it. I've noticed a few very minor things about the car that I thought you guys might be familiar with.. I'm a fussy bugger but I want to know if these things are just standard with the BA XR6's or whether I need to get them checked out at the first service:

1. auto-gearbox changing from 1st to 2nd is a little "clicky". It feels a little jumpy.. or maybe just a bit eager but I really feel a "notchy" pull when moving from 1st to 2nd in adaptive mode. The change from 2nd to 3rd is much smoother. Is this just a standard behavior from the gearbox ? It's done it since day 1.

2. Cruise Control - when I am about 110km and move into cruise.. there is a definite change in the engine and things fell a little "rougher".. not to the point where the car feels like it's gonna shake to pieces.. but a little course feel that I can definitely feel in my hands at the wheel

3. Oil dip-stick - sits quite loose in it's slot in the engine... there is a little rubber ring on it which I assume is the seal.. but other car's I've had fit the dipstick very snugly.. this one feels quite loose.. is this normal ?

Lastly, I have almost 1k on the clock now.. when it goes for it's 3k service should I insist on getting the oil changed (don't mind paying).. or should the run-in oil be left in there for longer, or even until the 15k ? Gotta confess I'm uncomfortable leaving oil for 15,000 clicks.. I've never left it that long for any of the cars I've owned.. especially when running in and all the little metal shavings and grime running around in a new engine.

p.s. Goddamn Shockwave is hard to keep clean.. my carwash (Meguirs) leaves water spots all over it and it's near impossible to shammy all the suckers off.

1000
1000 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-03-2005, 05:25   #2 (permalink)
Registered User
 
Join Date: Jul 2004
Posts: 16
Re: Help needed with XR6 Ba Mk2

Quote:
Originally Posted by 1000
Hey all.

I've had the XR 6 for around two weeks now and absolutely love it. I've noticed a few very minor things about the car that I thought you guys might be familiar with.. I'm a fussy bugger but I want to know if these things are just standard with the BA XR6's or whether I need to get them checked out at the first service:

1. auto-gearbox changing from 1st to 2nd is a little "clicky". It feels a little jumpy.. or maybe just a bit eager but I really feel a "notchy" pull when moving from 1st to 2nd in adaptive mode. The change from 2nd to 3rd is much smoother. Is this just a standard behavior from the gearbox ? It's done it since day 1.

2. Cruise Control - when I am about 110km and move into cruise.. there is a definite change in the engine and things fell a little "rougher".. not to the point where the car feels like it's gonna shake to pieces.. but a little course feel that I can definitely feel in my hands at the wheel

3. Oil dip-stick - sits quite loose in it's slot in the engine... there is a little rubber ring on it which I assume is the seal.. but other car's I've had fit the dipstick very snugly.. this one feels quite loose.. is this normal ?

Lastly, I have almost 1k on the clock now.. when it goes for it's 3k service should I insist on getting the oil changed (don't mind paying).. or should the run-in oil be left in there for longer, or even until the 15k ? Gotta confess I'm uncomfortable leaving oil for 15,000 clicks.. I've never left it that long for any of the cars I've owned.. especially when running in and all the little metal shavings and grime running around in a new engine.

p.s. Goddamn Shockwave is hard to keep clean.. my carwash (Meguirs) leaves water spots all over it and it's near impossible to shammy all the suckers off.

1000
Howdy 1000 - great color choice if I may say so!

1. The gearbox is very tight from new. Mine was also much more notchy in adaptive mode than in "D" but its really losened up now and very "buttery". I've got a bit under 15,000kms now. I'd say its still early days for you - the boxes definitely take some time to losen up. Slowly engaging Reverse is also a standard feature of the box - a bit of a pain when reversing up steep driveways in a hurry when the engine is hot.

2. It could be some exhaust resonance, wheel alignment issue or semi-round tyre. I'd get it checked out. I can't say mine's harsh at all at 110km/h.

3. Standard feature - no oil leaks though. I noticed this too.

As for the oil change, i switched to Shell 15w50 semi-synth with a PureONE filter after 5000km, letting the engine bed in for a while with the original mineral oil. The oil that came out was quite thin, dirty and greasy looking. I would avoid fully synth until at least 10000km.

I doubt the water marks are from the meguires - *joke* you do hose it off with water don't you? Its definately not easy to keep, but when its clean its definately a crowd magnet.

Enjoy your T.
shockwave is offline   Reply With Quote
Old 05-04-2005, 03:07   #3 (permalink)
BA FALCON XR6™
 
FPV TURBO's Avatar
 
Join Date: Jun 2004
Posts: 938
Re: Help needed with XR6 Ba Mk2

Yeh same car same colour here..

I also found that 1st to 2nd was very harsh when I first got it and was worried, with 8000 kms now it seems to have smoothed out.

Not sure about the 110 issue...

I changed the oil in mine at 6000 kms as one of my mates works at the dealer and he said to atleast leave the running in oil in till 5000 or so, which I did. The car feels much quicker now but I have put a K&N in it and also a Typhoon Snorkle.
FPV TURBO is offline   Reply With Quote
Old 05-04-2005, 03:42   #4 (permalink)
Magnificence in Motion
 
XcelR8's Avatar
 
Join Date: Sep 2004
Location: FPV's website
Posts: 318
Re: Help needed with XR6 Ba Mk2

Quote:
Originally Posted by 1000

p.s. Goddamn Shockwave is hard to keep clean.. my carwash (Meguiars) leaves water spots all over it and it's near impossible to shammy all the suckers off.

1000
It's not the Meguiars, it's the minerals and salts in the tap water. Try taking the high pressure nozzle off and running the water over the car gently for a final rinse, it makes the water sheet off and there are less spots to chamois off. I hope that helps.
__________________

I said to the ICWS ( In Car Whingeing System )
"What's the problem, it's a victimless crime...except for him, he lost!"


XcelR8 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Australian Ford's Discussion > Australian Falcons



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 22:15.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.