New car: AUIII Forte - issues - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
» Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Australian Ford's Discussion > Australian Falcons
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Australian Falcons Discuss the australian born and bred models here. Includes the 80's 90's and present day Falcons offered by Ford Oz.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 01-07-2005, 23:45   #1 (permalink)
Registered User
 
Join Date: Dec 2004
Posts: 7
New car: AUIII Forte - issues

There are a few small niggles with my new '02 Falcon Forte AUIII. First problem, the cruise control does not seem to handle high speeds very well, especially going along a freeway that ascends by about 7%. The cruise will move backward and forward between 98 and 105km. When I return back to 60k speeds, it does not seem to be as stable at holding the kms as beforehand, before I went on the freeway. Is it a fault with the cruise?

The small screeching noise with the AU when driving slowly - i've heard it on alot of AU taxis and I also have it on mine - what is it, is it a problem, and is it worth fixing.

When I was doing a u-turn, once completed I sped up and responded fine for a second but then just wouldnt respond to accellerator for half a second then went fine - not the type of no response you get when you take off fast.

Adding on to that, my engine seems to stall a bit sometimes on startup, cranks longer than it should.

It came with 6 months remaining factory warranty, I take it I need to get a service before they can look at these issues and fix them? What could be causing these problems, and whats involved in getting them fixed?

Cheers.
timeshift is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-09-2005, 16:17   #2 (permalink)
AU3 BT1
 
scruba's Avatar
 
Join Date: Jul 2003
Location: North Brisbane
Age: 39
Posts: 199
Re: New car: AUIII Forte - issues

don't wait for a service. book it in for warranty work.

i did that and all fixed no questions asked.

what is your location?
__________________
Our new ride - Narooma Blue Forte BT1 06/2002 AU3
My Falcon is here
AU1 Fairmont Galaxy Blue (Company Car)
Brisbane Car Detailers We share your passion for cars
scruba is offline   Reply With Quote
Old 01-10-2005, 00:06   #3 (permalink)
Registered User
 
Join Date: Dec 2004
Posts: 7
Re: New car: AUIII Forte - issues

Adelaide. Stillwell Ford is my closest - would that be the best place?
timeshift is offline   Reply With Quote
Old 01-12-2005, 18:10   #4 (permalink)
AU3 BT1
 
scruba's Avatar
 
Join Date: Jul 2003
Location: North Brisbane
Age: 39
Posts: 199
Re: New car: AUIII Forte - issues

I'm in Brisbane but give them a go.

Other ppl on this site may know the team there so ask around for recommendations etc.

Cheers,
__________________
Our new ride - Narooma Blue Forte BT1 06/2002 AU3
My Falcon is here
AU1 Fairmont Galaxy Blue (Company Car)
Brisbane Car Detailers We share your passion for cars
scruba is offline   Reply With Quote
Old 01-12-2005, 23:59   #5 (permalink)
WASHERE
 
WASHERE's Avatar
 
Join Date: Jan 2005
Location: melbourne
Age: 29
Posts: 16
Re: New car: AUIII Forte - issues

My guess would be your accelerator cable. If the cruse control is operating off the wire, possibilities are that it might be lose on it’s connection and high speeds could exploited that. As for the response issues the cable could be the blame again. The squeaking, could it possibly be your pads cleaning you discs. If not, Au’s and Ba’s a like have a factory defect where the discs go out of round that could be your problem.
My advice get it checked out while you still have warranty.
Good luck
WASHERE is offline   Reply With Quote
Old 01-16-2005, 23:14   #6 (permalink)
Registered User
 
Join Date: Dec 2004
Posts: 7
Re: New car: AUIII Forte - issues

Shall do.

I've been able to find exactly when the accelleration cuts out (this is unrelated to the cruise control issue). If I am turning a corner or a roundabout and I accellerate fast whilst im still not straight, thats when it tends to cut out for a second and prevents me from drifting :(
timeshift is offline   Reply With Quote
Old 11-01-2005, 04:42   #7 (permalink)
WASHERE
 
WASHERE's Avatar
 
Join Date: Jan 2005
Location: melbourne
Age: 29
Posts: 16
Re: New car: AUIII Forte - issues

could you have traction control?
__________________
Oh yeah!
WASHERE is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Australian Ford's Discussion > Australian Falcons



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
AUIII XR6 vs AUIII XR6 VCT ? Wampus Australian Falcons 80 12-28-2004 21:47
AUIII XR6 Clutch/ Gearbox problems micka Ford Ute Forum 18 10-02-2004 07:14
Fairmont Ghia AUIII V8 - Good or Not? Norton Australian Falcons 19 03-29-2004 16:25
Blueprint AUIII Forte? fte22 The Pub 6 02-01-2003 18:20

Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 10:54.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.