new problem - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Australian Ford's Discussion > Australian Falcons
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto EscrowInsurance

Australian Falcons Discuss the australian born and bred models here. Includes the 80's 90's and present day Falcons offered by Ford Oz.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 03-31-2003, 23:31   #1 (permalink)
EFI 351c TD CORTINA
 
qwikcorty's Avatar
 
Join Date: Oct 2002
Location: VIC, Narre Warren
Age: 31
Posts: 1,344
new problem

just the last couple of days my right indicator has been lit up when i put on the brakes. is this just a simple earth problem ? has anyone else had this happen?
__________________
1976 351c td cortina
qwikcorty is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-01-2003, 01:52   #2 (permalink)
300+rwkw DC LTD Member
 
LTDHO's Avatar
 
Join Date: Jul 2001
Location: Melbourne, Vic
Age: 39
Posts: 1,620
It sounds like a bad earth. It normally originates in the boot, due to the lights being so far away for the power (I think). Be sure the grounds are good and the paints removed from under the lug.
__________________
LTDHO
Power by Herrod 185rwkw
Power by me 313.6rwkw
Stereo by ///Alpine
LTDHO is offline   Reply With Quote
Old 05-14-2003, 06:26   #3 (permalink)
Go The Stone Brothers!
 
Join Date: May 2003
Location: Victoria
Posts: 54
Definetly a grounding problem... i know someone who had the same problem.

Check you wiring

- Ace
__________________
Who needs Holdens!?
When we have Fords!?
Ace_92EBII is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Australian Ford's Discussion > Australian Falcons



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
EA CFI 3sp auto (1989): Problem with idle return sambulance Inline 6 Tech 4 08-09-2003 04:06
95 CV engine problem 95CV Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71 9 04-22-2003 20:17
Acceleration problem and poor gas mileage mears Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007 3 02-21-2003 10:48
SHO stopper: Engine problem in high-performance Taurus angers fans Stacy94PGT Ford Worldwide News 0 10-23-2002 21:39
Defective GM engines $30+ Bilion problem. Discovery The Pub 11 03-21-2002 18:37

Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 02:35.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.