Weird mechanical problem, help please? - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Australian Ford's Discussion > Australian Falcons
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Australian Falcons Discuss the australian born and bred models here. Includes the 80's 90's and present day Falcons offered by Ford Oz.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 03-19-2003, 04:31   #1 (permalink)
jjj
Registered User
 
jjj's Avatar
 
Join Date: Mar 2003
Location: Qld
Posts: 278
Weird mechanical problem, help please?

I have noticed lately on long drives or around town , while driving the car loses all revs and power (tacho drops back to zero) and then a sec later resarts and everything is normal again. Would this be my TFI module or something else? It happens about every 2nd day, and is becoming annoying as i was overtaking a semi when it cut out for a sec or two!
jjj is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-19-2003, 22:38   #2 (permalink)
jjj
Registered User
 
jjj's Avatar
 
Join Date: Mar 2003
Location: Qld
Posts: 278
Surely this problem has happened to other e series falcons, any suggestions?
__________________
1997 EL Ford Fairmont.

1 Owner vehicle,
78000km's on the clock (12-1-05),
Showroom condition with all the fairmont goodies,
Metallic Silver.
jjj is offline   Reply With Quote
Old 03-20-2003, 00:00   #3 (permalink)
formerly sikEA
 
old_mate's Avatar
 
Join Date: May 2002
Location: Sydney
Age: 30
Posts: 2,142
What kinda car is it? Ie EA CFI, EA MPI, EB, ED etc etc

Mine does the same thing and i have never really bothered to look into it

I reckon its my gearbox though (4spd)
__________________
EL Fairmont
XY Fairmont


...mmm clevo...

Quote:
Originally Posted by Sundeep
And Yagz, come back in six months faggot
old_mate is offline   Reply With Quote
Old 03-20-2003, 00:02   #4 (permalink)
Phat Drift Damage Victim
 
XplodEd EA's Avatar
 
Join Date: May 2002
Location: Brissy
Age: 30
Posts: 985
How full is your fuel tank?
__________________
Ed
Phat Drift Damaged Cobalt Blue 1994 EF XR8 5 spd
Fully optioned - Sunroof, cruise, body kit
Stock as a Rock for the moment

TQE's
XplodEd EA is offline   Reply With Quote
Old 03-20-2003, 02:30   #5 (permalink)
jjj
Registered User
 
jjj's Avatar
 
Join Date: Mar 2003
Location: Qld
Posts: 278
It's a EA series II with 3.9l CFI, 4spd auto and yes the fuel tank is full, the problem seems to be becoming more frequent as it only use to happen once a month but now every 2nd day it occurs?
__________________
1997 EL Ford Fairmont.

1 Owner vehicle,
78000km's on the clock (12-1-05),
Showroom condition with all the fairmont goodies,
Metallic Silver.
jjj is offline   Reply With Quote
Old 03-20-2003, 03:01   #6 (permalink)
formerly sikEA
 
old_mate's Avatar
 
Join Date: May 2002
Location: Sydney
Age: 30
Posts: 2,142
ok does it clunk at say, when you are slowing down around the 15-20kph mark?

When my thing does it, i can feel the car slightly lock up and jerk, with a pretty audible thud

I am 99% sure its me box, i cain it too much and I know the 4 speeds dont like being abused. Oh and my car spent its former life towing a boat :)

Read up on these forums on how to do a tranny service yourself, then go from there. i havent done one on mine as yet cos im scared of all the little nasties im going to find.....
__________________
EL Fairmont
XY Fairmont


...mmm clevo...

Quote:
Originally Posted by Sundeep
And Yagz, come back in six months faggot
old_mate is offline   Reply With Quote
Old 03-20-2003, 03:05   #7 (permalink)
formerly sikEA
 
old_mate's Avatar
 
Join Date: May 2002
Location: Sydney
Age: 30
Posts: 2,142
I just read it happens when you drive....so probably count the box out

does it happen when you put your foot down, or just when at cruise? I also once had this problem, but it was gone after i did my head gasket. While the head gasket wasnt the cause, i replaced a lot of stuff at the time which may have contributed

things like Replaced Fuel Filter, Dissy cap and rotor button, got timing spot on, all leads and plugs replaced, ran some injector cleaner thru it and put Premium in it for a week. Also replaced air filter, cleaned ISC, throttle body etc etc.

Never returned again.
__________________
EL Fairmont
XY Fairmont


...mmm clevo...

Quote:
Originally Posted by Sundeep
And Yagz, come back in six months faggot
old_mate is offline   Reply With Quote
Old 03-20-2003, 06:00   #8 (permalink)
jjj
Registered User
 
jjj's Avatar
 
Join Date: Mar 2003
Location: Qld
Posts: 278
It happens while on a cruise, but I will try changing the things you mentioned like leads, fuel filter, dizzy cap and rotor and see what happens?
__________________
1997 EL Ford Fairmont.

1 Owner vehicle,
78000km's on the clock (12-1-05),
Showroom condition with all the fairmont goodies,
Metallic Silver.
jjj is offline   Reply With Quote
Old 03-22-2003, 18:25   #9 (permalink)
Registered User
 
Join Date: Feb 2003
Location: Cobram
Posts: 197
if the tacho drops and comes bcak in it sounds like dizzy module. workin RACV has taught me this a lot. if the auto is crook, all that will do is drop to third gear and go into limp home mode. i would get your dizzy sussed out cos when they go they really stop on ya, can't even baby them home. I paid 130 for a new dizzy in my car and the problem went away. I think its a dizzy problem.
__________________
Drive it like you stole it.....
tickfordboy is offline   Reply With Quote
Old 03-22-2003, 22:22   #10 (permalink)
Look! A flying orangutan!
 
Join Date: Mar 2003
Location: perth
Age: 31
Posts: 3,104
hell man if its a dizzy, just get another out the paper, they dont die that often i find. If you know somebody, they might even lend you it so you can find out...
__________________
Proud TQE Operator and President of SEFAG - the Society for the Elimination of Ford Automatic Gearboxes

Pacemaker headers + 2.5" exhaust
EF Fairmont interior
MP3 player
Lowered King springs
5 speed manual
EF motor

Newest mod: EF Ghia wiring loom and dash
mongrelEB is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Australian Ford's Discussion > Australian Falcons



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Weird Laser Problem darwin General Tech 2 03-23-2003 22:57
Weird problem! snavy General Tech 11 03-10-2003 09:54
really weird problem xr8_forever General Tech 3 12-07-2002 21:27
SHO stopper: Engine problem in high-performance Taurus angers fans Stacy94PGT Ford Worldwide News 0 10-23-2002 21:39
Defective GM engines $30+ Bilion problem. Discovery The Pub 11 03-21-2002 18:37

Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 19:14.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.